Solved my high idle hell after 2 years! Solution info here with pic. 84 380SL - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-20-2019, 05:25 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Mar 2017
Vehicle: 1984 380SL
Location: Connecticut
Posts: 47
Mentioned: 0 Post(s)
Quoted: 15 Post(s)
(Thread Starter)
Solved my high idle hell after 2 years! Solution info here with pic. 84 380SL

I practically changed everything from gas tank to engine including new idle computer, still had same symptoms: High idle, erratic idle, hard start when hot, low performance. While checking for vacuum lines I noticed when I moved the fuel cooler around my idle jumped from 500s to 2500s, chaotically. Just like while driving. First I though maybe a vacuum leak. But it turned out to be ELECTRICAL! The bracket that carries the fuel cooler, and the ignition coil, is used to ground two brown wires to the chassis. I'm sure they are leading to some sort of temperature and idle control sensors. People in the know can chime in. I checked the ground connectivity here and it was on and off based on pulling and pushing the bracket. So I removed the bracket, sanded back and cleaned the chassis contacts. Mounted it back with new bolts and washers and now I have a totally different car. It's rock solid at 500s, started like a champ when hot, and drove like a beast. If you have high idle, erratic idle, etc you should check and clean this connection before throwing bunch of time and money at it, like I have for the past two years.
Attached Thumbnails
Click image for larger version

Name:	High idle issue solution.jpg
Views:	28
Size:	81.2 KB
ID:	2514446  
dr_b is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-20-2019, 07:09 PM
BenzWorld Member
 
Franklyspeaking's Avatar
 
Date registered: Feb 2015
Vehicle: 1998 C280; 1987 560SL
Location: Southeast USA
Posts: 355
Mentioned: 3 Post(s)
Quoted: 79 Post(s)
Good work. Bad grounds can cause strange things with these cars. Thanks for sharing.
Franklyspeaking is offline  
post #3 of 5 (permalink) Old 05-20-2019, 07:35 PM
Outstanding Contributor
 
roncallo's Avatar
 
Date registered: Apr 2005
Vehicle: 1986 560SL with M120 V12 Engine, 1988 560SL Stock
Location: NC
Posts: 9,463
Mentioned: 8 Post(s)
Quoted: 297 Post(s)
Thanks for posting this. These kinds of thing can drive you crazy.
roncallo is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-20-2019, 08:03 PM
Outstanding Contributor
 
PanzerPuff's Avatar
 
Date registered: Dec 2013
Vehicle: 1987 560SL
Location: United States Ohio
Posts: 2,164
Mentioned: 31 Post(s)
Quoted: 859 Post(s)
outstanding info, will check for corrosion around grounds next time I'm out there!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PanzerPuff is offline  
post #5 of 5 (permalink) Old 05-21-2019, 03:15 PM
BenzWorld Senior Member
 
miko1aj's Avatar
 
Date registered: Sep 2012
Vehicle: '79 450SL, '04 CLK200 convertible; former A124, W210, A209.
Location: Galway, Ireland
Posts: 537
Mentioned: 4 Post(s)
Quoted: 104 Post(s)
Garage
Glad you got sorted dr b, and thanks for spreading tje knowledge - threads like this one are the salt of this forum, sure as hell you've saved some other people a headache 👍😊
miko1aj is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Great diagnostic videos on high idle hell Rhinoww R/C107 SL/SLC Class 0 05-29-2017 06:58 AM
85 380SL high idle - steps completed - help on electrical test picture this R/C107 SL/SLC Class 6 10-06-2015 01:34 AM
1981 380sl High Idle Jim Reed Motors R/C107 SL/SLC Class 1 07-09-2013 09:43 PM
another variation of high idle rkar R/C107 SL/SLC Class 4 05-28-2010 09:00 AM
test Jillian80 Test 5 06-09-2008 11:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome