Idle “hiccup” - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-20-2019, 11:35 AM Thread Starter
BenzWorld Member
 
frazierfrazier's Avatar
 
Date registered: Aug 2009
Vehicle: 1981 380SL
Location: baltimore
Posts: 394
Mentioned: 1 Post(s)
Quoted: 78 Post(s)
(Thread Starter)
Idle “hiccup”

Can’t think of a better way to describe it, but when the car is idling at a stop, for a split second the revs will drop very slightly, and the rear end of the car will jump up just a hair. Very intermittent. Sometimes I notice this under heavy acceleration, but the effect is that when it “hiccups”, you lose a bit of power. It’s REALLY irritating, and I’ve had this issue since day one, presumably.

It idles just fine otherwise. Some days it runs perfectly, without a single one of these incidents, other days it will do it once or twice and some days it’s really noticeable.

Changed all the plug wires after I did the timing chain, and that seemed to help a little, but I’m sure it’s all in my head.

Injectors are original, around 80k miles on them. Dump Techron in every once and awhile and can’t say I notice a difference. Stumped!
frazierfrazier is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-21-2019, 07:43 AM
BenzWorld Member
 
Jack Rushing's Avatar
 
Date registered: Apr 2009
Vehicle: 1985 500SL. Previous cars-190SL, 230S, 250SE, (2) 300SDs
Location: Meridian, MS.
Posts: 290
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
I have had this trouble. Found out it was a bad fuel injector.
frazierfrazier likes this.
Jack Rushing is offline  
post #3 of 3 (permalink) Old 04-22-2019, 06:02 AM
BenzWorld Elite
 
Weather Man's Avatar
 
Date registered: Dec 2008
Vehicle: 1984 380SL
Location: Key West FL USA
Posts: 2,268
Mentioned: 4 Post(s)
Quoted: 298 Post(s)
Yeah, when mine does that I know it is time to take it for a run at speed.
Weather Man is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
M120.982 W140 EPC light, 4,000rpm revlimit in 1st, rough idle, plus codes. Joe-V12 W140 S-Class 180 11-19-2018 09:42 PM
B200 Turbo occasional rough idle almost always only after engine fully warmed up W245Wiggler W245 B-Class 7 06-22-2018 09:23 AM
1983 380SL High idle zoltar R/C107 SL/SLC Class 20 07-22-2012 09:55 AM
M103 Idle problem, I've done some digging... questions akimball442 W126 S,SE,SEC,SEL,SD,SDL Class 18 06-12-2008 06:29 PM
Does anyone know where is the location of the idle control unit joconab R/C107 SL/SLC Class 6 05-23-2008 06:34 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome