High Beams not Working - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-11-2019, 10:28 AM Thread Starter
BenzWorld Junior Member
 
dhorton66's Avatar
 
Date registered: Mar 2019
Vehicle: 1985 380SL
Location: Tallahassee, FL
Posts: 11
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Garage
(Thread Starter)
High Beams not Working

Any suggestions what may be causing my brights not to work? New bulbs, Not getting a 12V reading on either fuse contact when brights switch engaged or not, fuse is good. When brights are switched on fogs and low beams shut off, just no high beams though.
dhorton66 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-18-2019, 10:35 AM Thread Starter
BenzWorld Junior Member
 
dhorton66's Avatar
 
Date registered: Mar 2019
Vehicle: 1985 380SL
Location: Tallahassee, FL
Posts: 11
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Garage
(Thread Starter)
No one has had this issue? I am thinking maybe in the blinker/Brights switch?
dhorton66 is offline  
post #3 of 5 (permalink) Old 04-19-2019, 11:51 AM
BenzWorld Elite
 
cushjbc's Avatar
 
Date registered: Dec 2010
Vehicle: 1973 450 SL
Location: Albuquerque
Posts: 1,646
Mentioned: 15 Post(s)
Quoted: 368 Post(s)
I have not had experience with this - going to the fuse box was smart. I would put a meter on the rotary light switch next, followed by the connector for the combination switch. Do you have a copy or access to the ETM for your car?

Page 112 is relevant to your symptoms - attached
Attached Files
File Type: pdf 83_84_85 etm-page112.pdf (91.7 KB, 8 views)

Brad Cushman
73 450 SL
cushjbc is online now  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-19-2019, 12:14 PM Thread Starter
BenzWorld Junior Member
 
dhorton66's Avatar
 
Date registered: Mar 2019
Vehicle: 1985 380SL
Location: Tallahassee, FL
Posts: 11
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Garage
(Thread Starter)
Thanks, I did not have this schematic.
dhorton66 is offline  
post #5 of 5 (permalink) Old 04-19-2019, 01:51 PM
Moderator
 
rowdie's Avatar
 
Date registered: Jun 2008
Vehicle: 1986 560SL: '84 500SL: '84 280SL 5 speed: other 107s
Location: OklaMoKan
Posts: 31,225
Mentioned: 51 Post(s)
Quoted: 109 Post(s)
Lifetime Premium Member
Does the high beam flash function work? Should work independent of the light switch.
rowdie is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Simple question? How to keep high beams on? tusabes W220 S-Class 2 10-09-2015 06:25 AM
Turn signal switch- high beams statred450sl R/C107 SL/SLC Class 6 03-17-2014 03:53 PM
1999 slk230 horn and high beams not working cpairways R170 SLK-Class 2 11-05-2009 08:36 PM
test Jillian80 Test 5 06-09-2008 11:28 AM
Bu-Xenon Question.. High Beams not working.. AC_ML W163 M-Class 5 09-26-2005 06:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome