Neutral Safety Switch - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-06-2018, 03:16 PM Thread Starter
BenzWorld Elite
 
RLT61's Avatar
 
Date registered: Jan 2016
Vehicle: 86 560SL
Location: Greater Hotlanta
Posts: 1,243
Mentioned: 12 Post(s)
Quoted: 332 Post(s)
Garage
(Thread Starter)
Neutral Safety Switch

i think the Neutral Safety Switch on my SL needs to be replaced. I can start the car regardless of the position of the shifter. The shifter feels normal and does not have any sloppiness. I did replace the bushings on the linkage a couple years ago.
I personally never messed with the Neutral Safety Switch but all the reading I did points to an internal short and the switch has to be replaced. Are there any other failure modes, other than a defective Neutral Safety Switch, that would exhibit this symptom?
RLT61 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-07-2018, 05:39 AM
BenzWorld Member
 
304065's Avatar
 
Date registered: Jan 2012
Vehicle: 2011 S212, 1978 R107
Location: New Amsterdam
Posts: 218
Mentioned: 1 Post(s)
Quoted: 45 Post(s)
No, it shouldn't turn over with the shifter anywhere other than park or neutral.

https://www.benzworld.org/forums/r-c...ty-switch.html

2011 S212 E350 Tansanitblau

1978 R107 450SL 735 AstralSilber
304065 is offline  
post #3 of 4 (permalink) Old 10-07-2018, 05:44 AM Thread Starter
BenzWorld Elite
 
RLT61's Avatar
 
Date registered: Jan 2016
Vehicle: 86 560SL
Location: Greater Hotlanta
Posts: 1,243
Mentioned: 12 Post(s)
Quoted: 332 Post(s)
Garage
(Thread Starter)
Quote:
Originally Posted by 304065 View Post
No, it shouldn't turn over with the shifter anywhere other than park or neutral.

https://www.benzworld.org/forums/r-c...ty-switch.html
I found your thread yesterday after I posted my question. Should have done a search first, but thanks for posting the link.
RLT61 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 10-07-2018, 12:08 PM Thread Starter
BenzWorld Elite
 
RLT61's Avatar
 
Date registered: Jan 2016
Vehicle: 86 560SL
Location: Greater Hotlanta
Posts: 1,243
Mentioned: 12 Post(s)
Quoted: 332 Post(s)
Garage
(Thread Starter)
I don’t think this switch ever worked since I have the car. I am so used to putting my foot on the brake (shifter is usually in park) when I start the car, that I never noticed it not working. As far as the back-up lights, never noticed that they are not working either. Wonder what else is not working- LOL.
RLT61 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome