A few stupid questions - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 12 (permalink) Old 02-09-2017, 01:51 PM
Outstanding Contributor
 
MBGraham's Avatar
 
Date registered: Oct 2006
Vehicle: '72 350SL, '85 300D, '98 E320, '19 Subaru Outback (sold '14 GLK250)
Location: Ont, Canada
Posts: 9,585
Mentioned: 2 Post(s)
Quoted: 20 Post(s)
Quote:
Originally Posted by stradivari1689 View Post
Slams a bit when going into drive from park (but not so much into reverse), am hoping it has to do with a high cold idle (1500-1700 in park), otherwise it shifts fine whilst driving.
That is high. Engine would normally surge once rpms go above ~1500rpm (ECU cuts off fuel then turns it on again at just under 900rpm). You can adjust the rpm down a bit using the idle screw just next to the AAV front of engine. When everything (especially AAV) is working right, cold idle will be quite a bit lower - maybe 1200rpm in summer?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1972 350SL 4.5L, E320, 300D, Outback 2.5 - near Kingston, Ontario
MBGraham is offline  
Sponsored Links
Advertisement
 
post #12 of 12 (permalink) Old 02-09-2017, 02:01 PM Thread Starter
BenzWorld Member
 
Date registered: Jun 2007
Vehicle: Ex 202.028, 124.028, 107.045 (with 117.967), 129.067; now 163.154, 203.764, 129.066
Location: So. Cal.
Posts: 210
Mentioned: 0 Post(s)
Quoted: 45 Post(s)
(Thread Starter)
PO only had bits and pieces of the service history, all recent, although he's owned the car since around 1987. One curious item from a few months ago after I'd initially looked at the car was a reference to a "CIS unit with cracks and tape" that may be contributing to the idle problem. I'm interpreting that as a mis-naming of the D-jet ECU, although I haven't looked under the glove box to verify the physical condition of that unit.

I do see the AAV and idle screw very clearly and will try fiddling with those as well.
stradivari1689 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome