Fuel sender repair - Page 4 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 41 (permalink) Old 02-22-2016, 02:32 AM
BenzWorld Newbie
 
Date registered: Feb 2016
Vehicle: 1972 350SL Mercedes Benz
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
hi what if the smaller wires are broken
ec23 is offline  
Sponsored Links
Advertisement
 
post #32 of 41 (permalink) Old 10-05-2016, 02:12 PM
BenzWorld Junior Member
 
Date registered: Sep 2015
Vehicle: 1986 Mercedes 560sl
Location: Belgrade, Serbia
Posts: 21
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
I have cleaned my fuel tank and fuel sender. After cleaning I now have a working fuel sender unit showing exact amount of fuel in the tank but the fuel empty light is on all the time. The fuel tank and sender were very clean concerning the age of the car I expected a lot of dirt and sludge. I have opened and checked again all contacts/wires in fuel sender and looks fine except that when checked it sends electrical signal from bottom contacts and top contacts as well, like there is no ground contact in the fuel sender unit. Any experience or opinion on the mater, since it is to annoying watching fuel empty lamp lightning all the time. Fuel level as I said is working fine and precise.
barola is offline  
post #33 of 41 (permalink) Old 10-05-2016, 02:23 PM
BenzWorld Junior Member
 
ivanuf's Avatar
 
Date registered: Aug 2015
Vehicle: 1981 500SL
Location: Puerto Rico
Posts: 48
Mentioned: 0 Post(s)
Quoted: 10 Post(s)
I had the same problem, but got lazy and removed the low fuel light from the cluster.
ivanuf is offline  
Sponsored Links
Advertisement
 
post #34 of 41 (permalink) Old 10-05-2016, 02:37 PM
BenzWorld Junior Member
 
Date registered: Sep 2015
Vehicle: 1986 Mercedes 560sl
Location: Belgrade, Serbia
Posts: 21
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Quote:
Originally Posted by ivanuf View Post
I had the same problem, but got lazy and removed the low fuel light from the cluster.
Thanks for the reply.

I think I will do the same and take out the low fuel light bulb from the tachometer if it doesn't fix itself in couple of days. Once when I feel it with gas the light went out for some time but now it stays all the time no matter empty or full tank.
barola is offline  
post #35 of 41 (permalink) Old 05-12-2019, 02:28 PM
BenzWorld Junior Member
 
Date registered: Nov 2018
Vehicle: 1987 560sl (chrome bling now removed), 2002tii, FJ40, FJ62, M5
Location: Richmond, VA
Posts: 8
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Garage
On my '87 560sl, I was getting erratic fuel level readings. There was no reading when first started. The gauge would then activate after about 5 minutes of driving. The gauge activated more quickly when full of near full. It took longer the lower the tank. So, I took out the sending unit and it looked brand new. I went ahead and took it apart, which was very easy. Again, it looked brand new inside. The thin resistance wire was broken. I tried to re-solder the wire to the bottom connections, but with no luck. The soldering was so hard on that tiny tip and tiny wire, that I ended up melting the plastic of the bottom piece.

Does anyone have a picture that shows how the resistance wire is routed? Is it soldered at the bottom, running up through the sides of the float, and then a continuous loop through the top piece and the two bent loops?

If I can find the right wire, it might save me the $200 part.
TIA,
fjinva is offline  
post #36 of 41 (permalink) Old 05-12-2019, 10:18 PM
BenzWorld Elite
 
okyoureabeast's Avatar
 
Date registered: Mar 2017
Vehicle: 1984 380SL
Location: North America
Posts: 1,810
Mentioned: 6 Post(s)
Quoted: 605 Post(s)
Quote:
Originally Posted by fjinva View Post
On my '87 560sl, I was getting erratic fuel level readings. There was no reading when first started. The gauge would then activate after about 5 minutes of driving. The gauge activated more quickly when full of near full. It took longer the lower the tank. So, I took out the sending unit and it looked brand new. I went ahead and took it apart, which was very easy. Again, it looked brand new inside. The thin resistance wire was broken. I tried to re-solder the wire to the bottom connections, but with no luck. The soldering was so hard on that tiny tip and tiny wire, that I ended up melting the plastic of the bottom piece.

Does anyone have a picture that shows how the resistance wire is routed? Is it soldered at the bottom, running up through the sides of the float, and then a continuous loop through the top piece and the two bent loops?

If I can find the right wire, it might save me the $200 part.
TIA,
That wire is a special type of wire that goes by the name Nichrome. It increases resistance over a certain amount of length which is how the sender knows the level in the tank.

This thread explains one guy who tried to fix his w123's sending unit. Fuel Sender Nichrome wire - PeachParts Mercedes-Benz Forum

I know I read another thread somewhere where a guy actually did acquire some Nichrome wire and attempted to do that. However, the resistance/ft ratio was never close enough to OEM which resulted in a misreading by the gauge.

He ultimately gave up and spent the money for a new sender.

Not to discourage you, but this is a rabbit hole that I would say not to bother. Bite the bullet and get a new OEM sender. I tried to do the same and gave up after I ran out of gas like an idiot. Not worth trying to be penny wise and pound foolish.
okyoureabeast is offline  
post #37 of 41 (permalink) Old 05-13-2019, 09:19 AM
Premium Member
 
Jyuma's Avatar
 
Date registered: May 2017
Vehicle: 1983 380 SL
Location: Long Island, New York USA
Posts: 1,991
Mentioned: 13 Post(s)
Quoted: 708 Post(s)
Premium Member
Garage
I too refused to spend $200 bucks on a part that should cost much less. In the long run I gave up and went for the $200. Well worth not going through the aggravation I and others have gone through trying to replace the Nichrome wire.

However, if you must... take a Vernier caliper and measure the thickness of the Nichrome wire you need to replace. What you are looking to establish is the AWG (gauge) of the wire.
Here is a partial chart:
AWG size in thousandths
15 .057
16 .050
17 .045
18 .040

Obviously these sizes are very small but if remember correctly the wire in the sending unit is even smaller. Just find a chart to convert whatever the thickness of the wire you measure, to it's equivalent AWG and then find that AWG Nichrome wire on eBay. There should be plenty.

Good luck. bTw... Nichrome wire is known for it's ability to take heat (the heating coils in a toaster are Nichrome wire). It may require a lot of heat to get solder to stick to it. Probably best to make a mechanical connection and just make it captive with solder, otherwise you'll likely overheat the connection.

Nobody gets out of this life alive.
Jyuma is offline  
post #38 of 41 (permalink) Old 05-13-2019, 10:55 AM
BenzWorld Junior Member
 
Date registered: Nov 2018
Vehicle: 1987 560sl (chrome bling now removed), 2002tii, FJ40, FJ62, M5
Location: Richmond, VA
Posts: 8
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Garage
Thanks everyone for the responses. I tried to solder that original wire and it would not take the solder, as mentioned above. I spent a lot of time and took a lot of care while trying to get the wire back in place. The bottom plastic holder eventually melted with the heat. I finally gave up and ordered a new sending unit. Bummer, since the rest of the unit was perfect. Looked brand new. I now am hopeful I do not need to add a ground wire to the instrument cluster as well, so that I can once again tell how much fuel I have. On to the next project. Thanks.
fjinva is offline  
post #39 of 41 (permalink) Old 05-13-2019, 01:09 PM
BenzWorld Elite
 
okyoureabeast's Avatar
 
Date registered: Mar 2017
Vehicle: 1984 380SL
Location: North America
Posts: 1,810
Mentioned: 6 Post(s)
Quoted: 605 Post(s)
Quote:
Originally Posted by fjinva View Post
Thanks everyone for the responses. I tried to solder that original wire and it would not take the solder, as mentioned above. I spent a lot of time and took a lot of care while trying to get the wire back in place. The bottom plastic holder eventually melted with the heat. I finally gave up and ordered a new sending unit. Bummer, since the rest of the unit was perfect. Looked brand new. I now am hopeful I do not need to add a ground wire to the instrument cluster as well, so that I can once again tell how much fuel I have. On to the next project. Thanks.
I would still add an extra ground wire to the cluster. You can buy a ground strap at any autoparts store for like $4, place it between the screws (metal to metal) on the cluster, and run it to the bolts that hold the steering column jacket to the chassis.

Easy insurance because the grounding in the cluster is questionable at best. Nothing is worse than dancing with gauges.
okyoureabeast is offline  
post #40 of 41 (permalink) Old 05-15-2019, 05:56 PM
BenzWorld Junior Member
 
Date registered: Nov 2018
Vehicle: 1987 560sl (chrome bling now removed), 2002tii, FJ40, FJ62, M5
Location: Richmond, VA
Posts: 8
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Garage
I figured I would close out my portion of this excellent thread, which has been very helpful. I tried to get the sender back in working condition. That small nichrome wire would not let me solder or keep from doing more harm. I ended up buying a new one for less than $200 on Amazon "Mercedes Parts Hub". Delivered in 2 days. Original Mercedes box and original Mercedes part. Took 12 minutes to install and I now have a fully functional fuel gauge. Easy enough. I will put a ground strap in when I go in to repair the clock.

BTW, I have kept the old sender which is virtually brand new, except for the broken nichrome resistance wire. If anybody needs spare parts, let me know. Thanks all! FJINVA
fjinva is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Roadster Forums > R/C107 SL/SLC Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 4 (1 members and 3 guests)
PEvans
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
Fuel sender removal jimmyl W123 E,CE,D,CD,TD,TE Class 6 06-11-2008 06:14 AM
Fuel sender curbill W123 E,CE,D,CD,TD,TE Class 2 04-17-2008 01:19 PM
Fuel level sender bigmellon Unimog 2 12-10-2007 07:45 AM
fuel sender repair? iNeon W123 E,CE,D,CD,TD,TE Class 3 03-20-2005 08:29 AM
Fuel Level Sender Repair article up in G-tech section of ClubGwagen site Hipine G-Class 0 11-17-2002 07:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome