Mercedes-Benz Forum - Reply to Topic
Topic: 722.409 Valve body Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-13-2019 11:10 PM
zpa001 Ok, Now is a time for my update. I took apart my trans valve body and cleaned it then put it all back together and now the trans is working like it should. I also changed all the trans fluid. I will be going on a 300 mile trip next weekend and that should tell if all is good. I did put in a K1 spring kit, but the slipping also before may have been from something other than the K1.
06-16-2019 11:36 PM
zpa001 I found this picture on a website with some other valve lineup. This picture was at the bottom of the page . I don't know why the put it on the page with the other valve body. But it is the same valve I have in my trans.
06-16-2019 11:21 PM
zpa001 This is the 2 part valve, the part that is in the bore first is the pressure control valve and the part next is the pressure control valve plunger. All these parts go together one after the other with no divide keeper in between. I took the first 2 parts out then the middle fell out on the table out of order and 1 last part was still in the bore. The valve I am talking about is on the far right in the picture.
06-16-2019 10:31 PM
zpa001 I do have the lower and top valve body back together and waiting on the gasket. It figs motorcycle weather and now the car takes a dump. So what better time than to get the motorcycle out.
06-16-2019 10:26 PM
zpa001 As soon as I find my camera cord I will put up the picture of the valve. From all of the picture in the book I have and the pictures with the valve I have seen it is not clear, kinda like a fussy fax picture. But I did find a picture of the valve that is clear at the bottom of a page in a PDF that I book marked shows all the parts in order. I will put something up soon.
06-16-2019 09:45 PM
christuna
Quote:
Originally Posted by dolucasi View Post
I suspect your picture. It was not posted.
your suspicion is correct
06-16-2019 03:42 PM
dolucasi
Quote:
Originally Posted by zpa001 View Post
Looking forward to what ??????
I suspect your picture. It was not posted.
06-14-2019 07:58 PM
zpa001 Looking forward to what ??????
06-14-2019 09:34 AM
christuna
Quote:
Originally Posted by zpa001 View Post
I will see if I can upload a picture. The pressure control valve is on the upper valve body at the other end from the manual valve on the side.
looking forward to this
06-11-2019 07:29 PM
zpa001 I will see if I can upload a picture. The pressure control valve is on the upper valve body at the other end from the manual valve on the side.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome