Mercedes-Benz Forum - Reply to Topic
Topic: 07 c230 fuel pump Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-05-2019 11:32 AM
[email protected] Yes sir I used a 7mm wrench it took over an hr to take off and put back on 1/8 of a turn at a time. But it’s done
06-05-2019 11:26 AM
rudeney Have you swapped it yet? Have fun with that band clamp. I had to use a "crazyball" or "skewdriver" to get to the screw.
06-04-2019 07:12 PM
[email protected] I appreciate everyone’s help I picked one up at auto zone. It was a "flex fuel" pump. Thanks again to everyone who took a couple min out of their days to help me
06-04-2019 07:07 PM
rudeney OK, that's the version that has external wiring for its level sensor. Some have the wiring that runs inside the tank along with the fuel lines and power supply to the sender unit on the left side. You will need a pump with the external level sensor wiring. Post your VIN and I can verify the part number for you.
06-04-2019 09:45 AM
AutohausAZ Do you have the Sport or Flex-Fuel model? We have pumps for both: https://www.autohausaz.com/catalog/c...bly?s=d&page=1
06-04-2019 09:14 AM
[email protected] This is the top of the passenger side
06-03-2019 08:53 PM
rudeney The right side (USA passenger) is the pump and all of its connections are inside the tank and run to the sender unit on the left side (USA passenger).
06-03-2019 06:43 PM
[email protected]
07 c230 fuel pump

So my 07 c230 won’t start, I have no pressure at the rail. I’m guessing fuel pump. When I take off back seat and the passenger side cover I find that I have a California style tank with the clamp and single electrical connector on the top etc. My question is can I use any of the replacement pumps most of the ones I’m seeing don’t have the socket on the top o the unit for me to plug in connector

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome