Mercedes-Benz Forum - Reply to Topic
Topic: Rattling noise upon startup Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-05-2019 11:28 AM
rudeney David, you should start a new thread for this since it has nothing to do with this particular topic of "rattle noise upon startup".
06-04-2019 08:23 PM
Davidsfarm Hi, I had my C-240 4Matic 2005 Benz at a dealer and had them put a used rear differential in it now it won't shift and a check engine light comes on and says incorrect gear ratio what could it be, it should not be the transmission it worked fine until they took the drive shaft out and grease the hanger bearings and they also installed a flexed disc in the back only didn't have the right one in the front so they put it back on and after it wont shift and you stop and put it in park i hear a loud clicking underneath of it and it sounds like a clicking and popping sound like the drive shaft is still spinning and hitting something nobody around here can figure it out and there is no benz dealership around here help. my car been laid up for months can't drive it, check the transmission fluid smells good and on full not leaking at all. and here's where the dealer told me to get one since they could not get one i asked the seller he said it came from a c 240 same as my car so i am so confused they think it has the wrong differential so they blame me for buying the wrong one is there different ones?

https://www.ebay.com/itm/01-05-MERCE...53.m2749.l2649


and also i have no idea if i posted on the right form lol I tried getting help before and i think i posted it on the wrong form. sorry
06-04-2019 06:02 PM
Benzyle Yes the belt tensioner is on the right..
on the left is the alternator and power steering pump...

Hard to tell what that noise is ,,,I hope it is not something to do with the recent timing chain replacement etc.

I would remove the belt and spin the pulleys by hand to see if there is any noise or wobble from any of them.

Then of course you could just ignore the noise like most people ,,,but it would be better to find out what is causing it.. but not by replacing parts which are working fine.
06-04-2019 05:01 PM
tmans19 Thanks for the advice!

Here's a video of the noise:

My mechanic did use some electronic ears to try and isolate the noise but even without them the noise is definitely coming from the left side of the engine bay. From what I understand, the tensioner is located on the right-hand side but please correct me if i'm wrong.

As for the alternator, I did think that $1100 was quite high for a new alternator to be fitted considering a genuine bosch unit costs around $400. Looks like i'll be looking for a new mechanic to do my repairs from now on. When the red warning light appeared, I took the car to battery world and they tested both the battery and alternator and said it was operating correctly and putting out correct voltages. If I have some time i'll definitely get it checked again for the exact voltage readings.
06-04-2019 02:21 AM
Benzyle $1100 is a lot for an alternator replacement ,,,should be about half that...at the most.
Your car's alternator should be putting out over 14v when idling ,,,,have it tested elsewhere if you can't do it..
There is a menu on the dash where you can see the voltage,,
Turn to ignition ,,press trip button three times,,,then use steering wheel buttons.
I wouldn't replace it unless it was not putting out correct voltage ,,or was making a big noise all the time.

Put a long screw driver to your ear and touch the part with the end and you will hear the noise better.
06-03-2019 08:57 PM
rudeney Just a guess, but maybe it is the tensioner. Although its pulley may spin smoothly, the spring in it that provides the tension can fail and make a "clucking" noise. A mechanic's stethoscope is a great tool for tracking down noises like this.
06-03-2019 07:14 PM
tmans19
Rattling noise upon startup

Hi All,

I've recently encountered an issue with my C180K. When I cold start the car and put it into gear there is an erratic rattling/ticking noise that occurs. This happens when the car is stationary and goes away completely once the car has been driven for a few minutes.

I had the timing chain, sprockets and adjuster magnets changed a couple of months ago so i've ruled that out as an issue. After taking the car to my mechanic, he diagnosed it as either a failing alternator or power steering pump. He let me have a look and rotate both the pulleys and they did make a ticking noise. We agreed that it was more likely an alternator issue because several weeks ago whilst driving, the red battery warning light appeared on my dashboard signifying that the battery was not charging however it has not come back since. After this incident, the alternator was tested and found to be operating normally and within usual parameters.

However, my mechanic suggested that I change the whole alternator out for a new one at $1100 aud.

I'm coming to this forum because i'm not completely convinced this is the right course of action. If the actual alternator was failing wouldn't there be more signs such as dimmed lights and wouldn't the noise be consistently there? Do the symptoms align more with a failing alternator pulley rather than alternator?

Water pump and tensioner pulley were also checked and found to be operating normally so I also have ruled that out as the potential issue.

Thanks in advance for any help!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome