Mercedes-Benz Forum - Reply to Topic
Topic: Temporary rough idle warm & cold after starting Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Yesterday 05:49 PM
JR420 Second update - can say now for certain after a few more miles I can say an adjustment is needed. Runs exceptionally well under throttle, but not the smoothest idle. I should have paid attention to.this, but it would appear as though the throttle mixture was adjusted previously correct?

Vehicle had rough idle when I bought it so wouldn't be surprised. Throttle plate does seem to have appropriate play before hitting plunger (not 100% certain)

Makes me wonder about EHA.
07-13-2019 11:46 AM
JR420 Update - Finally received back Fuel Distributor and test results of my injectors. 6 of 8 injectors failed either leak down, trigger or spray. Old diaphragm also appeared to have a number of pin holes and was badly worn. Put FD back on, new injectors and rest of hoses etc back together last evening. Did not jump fuel pump due to being able to see pic of my FD tested on flow bench from rebuilder. Within three or 4 30 second cranks it fired up. Few minor adjustments with stubborn to connect hoses that I thought were connected and it was time for a test drive.


So far I've put about 8 or so miles on it, not quite ready to say it runs perfectly just yet however the difference in throttle response and overall power is remarkable. I intend to put some more miles on it as I suspect there may be some air in the line going to the cold start injector perhaps and/or maybe some other air bubbles in a line or two that need to be worked through. Overall it's a big improvement! Will update with a bit more time on motor.

Side note I was able to find the throttle was not opening up fully and with a quick adjustment to the 10m bolt on the throttle bracket coming out of the firewall it's amazing how much more top end there is as well as proper trans kickdown.
07-07-2019 01:07 PM
lesguy Thanks. (Again)

Thinking at this price, won’t hurt to purchase and test. Even if the FPR currently in the car is good, would not hurt to have this as spare? https://rover.ebay.com/rover/0/0/0?m...2F163402043245
07-07-2019 11:31 AM
H.D.
Quote:
Originally Posted by lesguy View Post
... is my full throttle no upshift from 2-3 possibly related to my fuel system? ...
Only in as much as the fuel pump relay is involved, since it contains the kickdown shutoff function. As Heikkif mentions, it could be that either the rev limiter (fuel pump power cut-off) cuts in too early or the kick-down shut-off does not take place as it should 200 rpm below the rev limit.

You could either do what luckymike suggests, or you could check (easiest at terminal 9 of connector X26) if the (battery)voltage disappears at about 5600 rpm.

H.D.
07-07-2019 04:37 AM
Heikkif Maybe the rev limiter cuts in too early as fuel pump relay should shut off kick down at 5800 RPM. Anyhow fuel pump relay should shut off kick down if that was your question. As one releases pedal from kick down there is not happpening anything at the bowden cable or throttle linkages before kick down switch is released.
https://www.startekinfo.com/StarTek/...56/073-165.pdf
https://www.startekinfo.com/StarTek/...ine_560SEC.htm

At the top of the W126 forum page stickies there is link to service manuals.
07-06-2019 03:21 PM
lesguy Thanks H.D. I appreciate your knowledge sharing and guidance. I’m learning from it. Question: is my full throttle no upshift from 2-3 possibly related to my fuel system? Or is that most likely a coincidence? Doesn’t concern me excessively because I don’t redline this engine as a matter of routine. But still, one likes to have their drivetrain in top order.
07-06-2019 01:47 PM
H.D.
Quote:
Originally Posted by lesguy View Post
... with car at idle, I adjusted counter clockwise until it stalled, turned clockwise just a bit to restart, then clockwise until it stalled. Then for final adjustment turned the screw to halfway between both stall points ...
Doing that may sound somewhat logical, but it‘s a bad idea !

As explained in my Lambda control thread, with the Lambda adjustment screw … (I recommend to not even think of it as “mixture screw“, for reasons I explained in that thread) … turned according to anything other than EHA current (respectively duty cycle) without knowing what the EHA current (respectively the duty cycle) was before it was turned or how far exactly in what direction it has been turned, the duty cycle‘s diagnostic information is gone for good.

With this (unfortunately) being your situation now … if you place value on things to be reliably in proper condition & properly adjusted … install a good EHA who‘s adjustment screw setting is without doubt original. Then check and, if necessary, fix everything that has an effect on the fuel combustion. Don‘t forget what I said (in post 26) about dirt particles getting into the FD‘s lower chambers ! … Then check and, if necessary, adjust the duty cycle as described in post 2 of my Lambda control thread.

H.D.
07-06-2019 01:33 PM
lesguy Fully warmed, idling in park, can hear the slight low rpm hesitation https://youtu.be/pondxaqAqYQ
07-06-2019 09:33 AM
lesguy Idle when in gear: https://youtu.be/oCDNpqBdcdU
07-06-2019 09:28 AM
lesguy First of a series of videos...first cold start today. Was 90’s outside but a bit cooler in garage. A tad longer crank time to start when cold. Not touching accelerator pedal before nor during start. https://youtu.be/SzYxGSh2cBQ
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome