Mercedes-Benz Forum - Reply to Topic
Topic: Fuel Filling Issues Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-23-2019 08:43 AM
bkdc The problem is probably the charcoal cannister. The problem can start if the fuel tank has been topped off or overfilled. I had mine replaced under warranty and it fixed the problem.

I initially took my S550 in to the dealer and he gave me the MB notification regarding the pump design and that I should insert fully and then tilt down. However, this did not fix the problem. I took my car back and demonstrated the problem to the service advisor at the gas station.

No problems after the cannister was repaired.
01-30-2019 09:00 AM
PKariCL600
Quote:
Originally Posted by konigstiger View Post
See attachments if all is found to be fine.
This is great!!
Thank you!
01-26-2019 08:56 PM
konigstiger See attachments if all is found to be fine.
01-19-2019 11:08 AM
PKariCL600 Great thank you!! I actually just tried holding the nozzle upside down and it works perfectly but I will be taking it in for warranty just to check it out..thanks again
01-14-2019 11:43 AM
konigstiger If it happens at different filling stations, a bit early for 222 but could be fuel evaporation system (i.e.: charcoal canister/associated valve, etc.) have it checked under warranty.
01-14-2019 10:26 AM
PKariCL600
Fuel Filling Issues

Hey everyone...

Does everyone experience issues while trying to fuel their vehicles...
Everytime I go to fill it the pump keeps stopping and I have to pull the nozzle out for a sec and then start again...this happens every time...I can't just lock the handle in place and let it fuel on its own.

Anyone else have this issue?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome