Mercedes-Benz Forum - Reply to Topic
Topic: Self steering c32 Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-18-2019 08:42 PM
Benzyle OMG ,,,It's possessed !

Seriously ,,,must be something wrong with the rack in my opinion.
Don't bother replacing the pump ,,,it is fine.
Inside the rack and pinion valve there is a torsion bar ,,,it may have snapped or is not fixed at either end , causing power to be exerted when positioned off centre ,causing alternating movement.

You need the steering rack to be either repaired or replaced entirely.
05-13-2019 04:46 PM
E Vadnai Here's a video of what's actually going on. In this instance its not rocking back and forth on its own, I have to help it a little but at the end it goes by itself.

https://youtu.be/UYZ13nM-ry4
05-13-2019 03:57 PM
E Vadnai
Quote:
Originally Posted by PJmak View Post
Wait the car turns the wheels on its own as its sitting??
Yes sir it does. I believe it's only when there is a "load" on the system though. Whether that be a slight incline in the road or a hand placed on the wheel, Otherwise when holding the wheel straight or not moving it it doesn't force itself from side to side.
05-13-2019 10:51 AM
PJmak Wait the car turns the wheels on its own as its sitting??
05-07-2019 02:00 PM
E Vadnai
Self steering c32

Hey all, I just picked up a C32 for a steal of a deal. Ok Km's, good service record, good motor, just one big problem.

When the car is sitting, driving, in neutral... Etc. The steering wheel will move from side to side on its own, you can actually see it turn the wheels from outside the car when it's parked.

The previous owner replaced the rack and claims that there aren't any codes being thrown, but yet the problem is there. I'm planning on just starting with replacing the pump and going from there.

Just wanted to check to see if anyone else had seen this sort of thing before or if anyone had any advice to offer before I get started.

Much appreciated,
-e

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome