Mercedes-Benz Forum - Reply to Topic
Topic: c32 amg - p0410 Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-12-2018 09:36 AM
w220dad
Quote:
Originally Posted by Brian K View Post
Pull the egrís, strip them... clean them, new gaskets, hoses. Should look like new, like the old girl deserves. Everything should be fine then. O2 sensor just looking for a change when egr is called for.
Where might the EGR valve(s) be located?

Still having the same issue to this day, but have found out more. The inside of the hoses and tubes going from the secondary air pump to the two valve in front of the surge tanks have small amounts of condensation in them. Replaced all of these off of another C32 (which had completely dry inside and looked brand new). Cleared the CEL and drove for a few days until the CEL came back on with the same code, the P0410 secondary air injection system. Looked inside the secondary air injection hose and tube and also the two valves I replaced in front of the surge tanks, and they all had condensation build-up on them. I'm assuming this is also not normal and may have something to do with the P0410 code. Is there some sort of air check valve or exhaust gas valve that would allow condensation into these air tubes? Any help is appreciated as I still have the same problem months later
03-05-2018 08:09 PM
Brian K Pull the egrís, strip them... clean them, new gaskets, hoses. Should look like new, like the old girl deserves. Everything should be fine then. O2 sensor just looking for a change when egr is called for.
12-24-2017 09:00 AM
w220dad
c32 amg - p0410

Hi guys, I'm having codes p0410 (secondary air injection system) and sometimes having p0444 (evaporative emission system purge control valve circuit open). I read about the p0410 being most likely the air pump and relay, so I changed that out of a parts car I had. now the code comes back at random, and instead of coming on a startup, it does it at random after being driven. went on a 2 hour trip in the car and the code did not come on. then the next day went to the store and as soon as I parked, the code came back. I didn't think it could be the pump and relay, as I have read these only come on for about 30 to 40 seconds within the startup of the car. Any thoughts on this? thanks in advance

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome