Mercedes-Benz Forum - Reply to Topic
Topic: What have you done for your W210 today/lately? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Today 09:59 AM
Samp42 This week we celebrated a year with our E320. To recap the first year, it got an oil change along with a new belt, idler, and tensioner. Over the past year of driving, almost 5,000 miles, the oil consumption is nil and no fluid or coolant leaks.

At first there was a problem with the right rear brake light, the two small LCD displays on the instrument cluster were out, and there was some leakage around the sealing surfaces on the breathers. If you have a M112 or M113 you know what that is about. For each of those repairs I posted a writeup in the appropriate W210 thread.

Our E320 delivers 30 mpg+ driving a steady 70+ on the Interstate. In town it is more like 21-22. This car was born to run on the Interstate.... The driving and ride comfort are excellent.

Our thanks to all of you who have shared your knowledge and experience on this forum.
06-15-2019 10:00 PM
pt_700 reminded myself why cheap chinese mafs are not recommended... i got about a year out of a $20 unit before it started throwing the cel at altitude and maf codes to my reader. it's $30 replacement lasted about 10 miles before stalling on startup, throwing fuel trim errors & surging at low rpms. a $43 used unit (bosch) from an '04 320 at my local pick-n-pull seems to be doing the trick for now though!

in concept, it seems a relatively simple part; how much voltage to keep a little wire hot? why haven't the chinese been able to master that?
06-15-2019 04:38 PM
bluerooster Well, let's see, I pulled the radiator, repaired the lower cradle, re- installed the radiator, replaced the oil tubes on the left bank, changed the oil, and took it for a drive. While driving, CEL came on, code 304. So, tomorrow I try to get that sussed.

Will trade for a W140. (less of a PITA)
06-07-2019 07:02 PM
abataineh I finally fixed the sagging headliner on my 2002 Special Edition. The upholstery shop did a very nice job. I did most of disassembly of the interior and the shop took the headliner out of the car and installed back in. I did the remaining interior assembly. I payed $400.
I also took the same car to a body to refinish the roof molding strips and the antenna cover. They did a very good job and the car looks great. I spent $400.
Replacing the parts would have been around $550.
06-07-2019 06:57 PM
abataineh
Quote:
Originally Posted by southpaw View Post
Did this seal symptom include an occasional puff of blue on start up?
I did not notice blue smoke on start up. So, far the oil consumption has gone down significantly and the highway mileage increased by roughly 4 mpg.
06-04-2019 08:40 PM
serious Gave it a wash yesterday.

Mechanically speaking, over the past 7 months or so, I have:

1) done oil change
2) replaced engine vent hose (wrong one was installed)
3) replaced rear air filter mounts
4) replaced engine and transmission mounts
5) replaced driver side door brake
6) reglue door panel attachments
7) replaced front brake pads
8) replaced light fuse and a few bulbs, including front bulbs with new oem bulbs
9) replaced passenger headlamp assembly with genuine
10) replaced driver side headlamp lens with oem
11) replaced driver side headlamp harness (not oem, was not able to find one [emoji17])
12) replaced hood struts

Below I have before and after photos of the headlamps. In real life the headlamps now look much clearer than in photos I take.

Sent from my SM-G965U using Tapatalk
06-03-2019 10:14 AM
PriestJc So, I was driving the car a little harder than usual this past week, faster accelerations, etc. And the check-engine light went off on it's own.
Been driving quite a bit the past few days, lots of miles, and the CEL has not come back on. I get no codes no with the OBD2 reader now either.
06-02-2019 12:13 AM
BartMaster1234 Been wanting to do a double DIN conversion for the longest time, of course the only proper way to do this is to pay Mercedes $400 for the proper control stack trim and $50 for the double DIN cage. Was scouring eBay and the cheapest cage, trim, and COMAND bundle is $600.

Went to Pick-n-Pull the other week looking for a power window master switch, and the very first car I look at I hit the jackpot.

Paid $20 for all that including the instrument cluster.

What have you done for your W210 today/lately?-34r34r.jpg
06-01-2019 03:03 PM
dfleck63 Changed oil, oil filter, and air filter.

1999 E300
606,076 miles
I bought it new.
05-27-2019 01:59 PM
Smartchoice changed my front shocks.....car handles better
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome