Mercedes-Benz Forum - Reply to Topic
Topic: one of 3 strut mount bolts broken Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-10-2019 09:30 PM
Huachipato Personally I would think not too urgent. There torque on those bolts is quite low and I bet whoever did the install over torqued and busted the bolt.

I really think those bolts are only stressed when the wheel is if the ground. I'm sure others will correct me if I'm incorrect.

Sent from my Pixel 3 XL using Tapatalk
06-10-2019 05:23 PM
bmoe100
one of 3 strut mount bolts broken

I was working on my EGR and noted 1 of 3 bolts broken(right where it meets nut) on passenger front strut top mount. Strut is Arnott and still uses air system.
Is this an easy fix and are 2 bolts enough/how urgent is it?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome