Mercedes-Benz Forum - Reply to Topic
Topic: Rough idle and clunking in engine compartment Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-01-2018 01:03 PM
sknylil
Rough idle and clunking in engine compartment

I have a 2007 C230 that I have had issues with since buying. The man I bought is from had the check engine light diagnosed at a crank position sensor, had that changed out and car ran great for a few months. Last week it started running rough (feels like it’s missing in lower rpms and at idle). But it drives and run great at higher rpms. The intake manifold was functioning at 25%, replaced it and all the coils and plugs. Still has the small rough idle and clunking sound coming from the engine compartment. I’m at a loss. Any suggestions?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome