Gear stuck in P. Warning on dash - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-18-2019, 01:53 PM Thread Starter
BenzWorld Junior Member
 
it0022's Avatar
 
Date registered: May 2019
Vehicle: 2014 C-Class W204
Location: UK
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Gear stuck in P. Warning on dash

Hi



My Mercedes C class w204, 2014 has a red message saying "without changing gear consult workshop". The gears will not change and now stuck in P.

Mechanic said Transmission is fine as it "clicks" and it is an electrical fault. It all started when (in trying to fix a left window airbag warning) the connector under the passenger seat was disconnected and the ignition turned on. Put the connectors back but still giving this issue.

Can not be cleared with several good diagnostic machines. Shows a u010387 error code. "Communication with the electronic selector level module has a malfunction". It seems to me there was some short circuit or loss of communication in messing with the connector under the passenger seat and turning the car on while disconnected. I've checked all the fuse etc also.

Any ideas how to reset it or get it to work? Mechanics have no clue all saying different things.

Thanks
it0022 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-18-2019, 04:50 PM
Lifetime Premium Member
 
4DGeorge's Avatar
 
Date registered: Jan 2018
Vehicle: 2006 S500 (W220, Designo Espresso, AMG Sport, LWB)
Location: Houston, Texas, USA
Posts: 308
Mentioned: 15 Post(s)
Quoted: 40 Post(s)
Lifetime Premium Member
Garage
And disconnecting the battery had no effect?
I bumped into a similar issue today and found rebooting the electrical system (battery disconnected for 5 minutes) was the magic solution.
4DGeorge is offline  
post #3 of 7 (permalink) Old 05-18-2019, 05:26 PM Thread Starter
BenzWorld Junior Member
 
it0022's Avatar
 
Date registered: May 2019
Vehicle: 2014 C-Class W204
Location: UK
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Tried disconnecting battery twice for 30mins-1hour from negative terminal only. No difference. Plugs the iCarSoft MB ii back in and did not erase codes.
it0022 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-18-2019, 05:26 PM Thread Starter
BenzWorld Junior Member
 
it0022's Avatar
 
Date registered: May 2019
Vehicle: 2014 C-Class W204
Location: UK
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Tried disconnecting battery twice for 30mins-1hour from negative terminal only. No difference. Plugged the iCarSoft MB ii diagnostic back in and did not erase codes.
it0022 is offline  
post #5 of 7 (permalink) Old 05-18-2019, 06:27 PM
Lifetime Premium Member
 
4DGeorge's Avatar
 
Date registered: Jan 2018
Vehicle: 2006 S500 (W220, Designo Espresso, AMG Sport, LWB)
Location: Houston, Texas, USA
Posts: 308
Mentioned: 15 Post(s)
Quoted: 40 Post(s)
Lifetime Premium Member
Garage
Did you happen to unhook any of the connectors that go to the gear selector box?
4DGeorge is offline  
post #6 of 7 (permalink) Old 05-19-2019, 07:02 AM
BenzWorld Elite
 
noetico's Avatar
 
Date registered: Feb 2015
Vehicle: 2002 Mercedes ML320, Mercedes 190E 2.3L (sold), 2001 Mercedes c320(gone)
Location: Abuja, Nigeria
Posts: 1,272
Mentioned: 10 Post(s)
Quoted: 220 Post(s)
Garage
Confirm your brake lights come on when you press the brakes...

Also have a look at all the CAN points in the vicinity of where you worked... Ensure all is well plugged in.

I also think you should read more codes from AAM, Central gateway, EAM in addition, see if you find anything of interest.


Sent from my iPhone using Tapatalk

Kent
noetico is offline  
post #7 of 7 (permalink) Old 05-19-2019, 10:27 AM Thread Starter
BenzWorld Junior Member
 
it0022's Avatar
 
Date registered: May 2019
Vehicle: 2014 C-Class W204
Location: UK
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
So finally found the solution. Thanks for your input!
Whilst mechanics were quoting me >1k to open the transmission or engine...the answer lay very simply: fuse issue.
Changed around the fuse in passenger compartment side and fixed the job. Gears happily change and move

Now I need to fix my original issue:

LEFT WINDOWBAG MALFUNCTION, CONSULT WORKSHOP. Using diagnostic kit it shows: DTC ERROR "B002113 - THE SQUIB FOR THE LEFT WINDOWBAG/HEADBAG HAS A MALFUNCTION. THERE IS A OPEN CIRCUIT"

UK vehicle to left side = passenger side. Checked the fuse for sure this time. Checked connectors under seat thoroughly also.

Any advice?
it0022 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
List of Fault Codes....(DTC) sgtpepperaut W163 M-Class 17 Today 03:17 PM
Mercedes-Benz Diagnostic Trouble Codes (DTC) for 1996+ models GeeS General Mercedes-Benz 45 03-23-2019 06:04 AM
Weird Stuck in Gear Problem? remix919 C209/A209 CLK-Class 15 10-14-2013 05:43 PM
2003 C32 - PLEASE HELP - Car crawls and sticks in 2nd Gear (Part 1 of 2) 115jcso W203 C32 AMG, C55 AMG 1 04-24-2010 02:54 PM
Mercedes Fault Codes isarescu R170 SLK-Class 8 03-21-2008 08:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome