OM642 - Engine bad knocikng - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-18-2019, 02:55 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2019
Vehicle: 2007/W221/S320cdi
Location: Hungary
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
OM642 - Engine bad knocikng

Dear Members,

I am knew here, so please do apologize me if this topic came up already.

I have a Mercedes W221 S320 cdi from year 2006, and I have a big problem.

After driving 100 km on motorway, I stopped the car and it was very difficult to start again the engine and started to knocking. The first step was to replace 6 injectors (they were leaking), but it did not solved the problem.

Here is a video about the sound of the engine



Even before the injectors have been replaced, we went a few kilometers with the car, at the beginning the knocking was less loud, but then when the engine warmed up it became worse and the engine stopped, and didn't start again. After 1 hour of waiting it started again. During the idle the car is shaking and it lost power. Sometimes it smokes heavily grayish diesel smoke. Do you have any tips?

Thanks in advance,
Andrew
Gonczy Andras is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-27-2019, 08:08 AM
ot1
BenzWorld Veteran
 
Date registered: Apr 2007
Vehicle: 2006 E320 CDI
Location: Midwest USA
Posts: 610
Mentioned: 4 Post(s)
Quoted: 145 Post(s)
Sounds like a lifter ticking, dirty oil causes this clogging most of the time, you could change the oil again with a quality high detergent oil
ot1 is offline  
post #3 of 3 (permalink) Old 08-14-2019, 08:57 AM
BenzWorld Junior Member
 
Date registered: May 2003
Vehicle: Only MB
Location: The Bay Area
Posts: 17
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
You need to get plugged into Xentry and read the ECM--It really sounds like you have an injector/cylinder firing out of time or improperly, and your battery voltage seems low as well, the resistance as you start is telling us that.

How many KMs on the engine?
markg612 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > Diesel Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome