Premium or Lifetime subscription... - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-07-2017, 11:00 AM Thread Starter
BenzWorld Member
 
peter2772000's Avatar
 
Date registered: Nov 2017
Vehicle: 2007 FJ, 2012 BMW X6, 2013 ML350 BT
Location: Montreal Qc/Cape Coral FL
Posts: 86
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Premium or Lifetime subscription...

...as compared to regular.

If I pay Lifetime, will 99% of the ads be gone? The chart stating the benefits of premium and Lifetime versus regular only state "less ads". That's like saying less dead LOL
Seriously, this site slows both my laptops down so much due to all the bloody ads. The "other" site has only one ad and I paid nothing. But I'd gladly pay here if only one ad remains seen.

Thx,

Peter
peter2772000 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-08-2017, 04:25 AM Thread Starter
BenzWorld Member
 
peter2772000's Avatar
 
Date registered: Nov 2017
Vehicle: 2007 FJ, 2012 BMW X6, 2013 ML350 BT
Location: Montreal Qc/Cape Coral FL
Posts: 86
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Nothing?

It just took my work desktop 22 seconds to load....
peter2772000 is offline  
post #3 of 8 (permalink) Old 12-08-2017, 07:04 AM
Administrator
 
administrator's Avatar
 
Date registered: Mar 2006
Vehicle: Mercedes c350
Location: Toronto, Ontario
Posts: 3,001
Mentioned: 8 Post(s)
Quoted: 302 Post(s)
Lifetime Premium Member
Garage
Hey there,

Please allow 24-48 hours for a response from the admin team. I can't say that 99% of the ads will be gone when you sign up for premium or lifetime membership but seeing ads will be significantly reduced. You can always try it out to see for yourself and if you're not satisfied, we can refund your money within 60 days of purchase.

When you say the site slows down both your laptops, have you noticed if the browser is hanging onto anything at the bottom left corner? It would say something like "Waiting for xxxxxx...." x being whatever script or ad the page is waiting on to load. Also, is this just happening on certain pages or across the whole site (slowness)?


Cheers,
Nate


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

If you have any suggestions or feedback, please PM me.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


test
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
administrator is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 12-08-2017, 01:40 PM Thread Starter
BenzWorld Member
 
peter2772000's Avatar
 
Date registered: Nov 2017
Vehicle: 2007 FJ, 2012 BMW X6, 2013 ML350 BT
Location: Montreal Qc/Cape Coral FL
Posts: 86
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
The page changes, then I see the rotating symbol in my upper screen that shows that the page isn't completely loaded. Until the symbol stops rotating I counted 22 seconds once. Only when the symbol stops rotating am I able to scroll down the page.

whole site, no place is spared. I tell you, it's freakin' torture. I'll wait for contact by the team, and thx for the response!
peter2772000 is offline  
post #5 of 8 (permalink) Old 12-10-2017, 07:36 AM Thread Starter
BenzWorld Member
 
peter2772000's Avatar
 
Date registered: Nov 2017
Vehicle: 2007 FJ, 2012 BMW X6, 2013 ML350 BT
Location: Montreal Qc/Cape Coral FL
Posts: 86
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Bump.....
peter2772000 is offline  
post #6 of 8 (permalink) Old 12-11-2017, 08:41 AM
Administrator
 
administrator's Avatar
 
Date registered: Mar 2006
Vehicle: Mercedes c350
Location: Toronto, Ontario
Posts: 3,001
Mentioned: 8 Post(s)
Quoted: 302 Post(s)
Lifetime Premium Member
Garage
Quote:
Originally Posted by peter2772000 View Post
The page changes, then I see the rotating symbol in my upper screen that shows that the page isn't completely loaded. Until the symbol stops rotating I counted 22 seconds once. Only when the symbol stops rotating am I able to scroll down the page.

whole site, no place is spared. I tell you, it's freakin' torture. I'll wait for contact by the team, and thx for the response!
are you logged in when they happens? and what browser are you running. check to see if they're up to date. If you're using Chrome, it should be 62.xx

also, as a lifetime member/premium member, there's an option to remove the panel to the right. but you need to be logged in to cash in all the features.

Lee


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

If you have any suggestions or feedback, please PM me.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


test
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
administrator is offline  
post #7 of 8 (permalink) Old 12-11-2017, 01:37 PM Thread Starter
BenzWorld Member
 
peter2772000's Avatar
 
Date registered: Nov 2017
Vehicle: 2007 FJ, 2012 BMW X6, 2013 ML350 BT
Location: Montreal Qc/Cape Coral FL
Posts: 86
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
(Thread Starter)
Dunno which version of IE, but I have the issue at work, at home on a brand-new and older 'puter as well as my home 'puter. It's the ads bud, plain & simple.

If I pay for the lifetime membership, which I have no issue doing, and the problem persists, can I cancel/get refunded as per the earlier post above? 'Cause I read that any purchases are non-refundable....
peter2772000 is offline  
post #8 of 8 (permalink) Old 12-12-2017, 08:10 AM
Administrator
 
administrator's Avatar
 
Date registered: Mar 2006
Vehicle: Mercedes c350
Location: Toronto, Ontario
Posts: 3,001
Mentioned: 8 Post(s)
Quoted: 302 Post(s)
Lifetime Premium Member
Garage
Quote:
Originally Posted by peter2772000 View Post
Dunno which version of IE, but I have the issue at work, at home on a brand-new and older 'puter as well as my home 'puter. It's the ads bud, plain & simple.

If I pay for the lifetime membership, which I have no issue doing, and the problem persists, can I cancel/get refunded as per the earlier post above? 'Cause I read that any purchases are non-refundable....
Hello there,

Please give it a try on Chrome, Firefox of Edge
IE is no longer updated by Microsoft. The forum will not run 100% on IE.

Hope this helped.

Ed


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

If you have any suggestions or feedback, please PM me.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


test
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
administrator is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Community Help Section > Community Help

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome