Airmatic fuse keeps blowing up after front air strut replacement - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-26-2018, 08:22 PM Thread Starter
BenzWorld Member
 
Date registered: Jan 2010
Vehicle: 2003 E500 W211.070
Location: Atlanta, GA
Posts: 55
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Airmatic fuse keeps blowing up after front air strut replacement

I have a leak on the driver side front air strut. I bought a new one and did the DIY myself to replace it. The first thing was I removed the relay locates at the front fuse box. I didn’t remove the battery. After I changed the strut, I plugged everything back on and the car will not pump up. The 4 shocks where down with the sign “Vehicle too low”. Well it first says “vehicle raising wait” but nothing happens.
Don’t know what else to do so I took it to a nearby mechanic who told me the Airmatic fuse was blown and when he puts another fuse, that one blown as well. He’s suggestion was I need a new air compressor. I’m not really satisfy with that diagnosis because the air compressor was working fine before I removed the air strut and put a new one in.
What else can cause this problem? One thing I noticed was when I was replacing the relay, the seat for the relay dropped down a bit. It was hard for my big hand to reach so I guess I pressed it in a bit hard.
kaybal is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-27-2018, 07:16 AM
Outstanding Contributor
 
konigstiger's Avatar
 
Date registered: Jan 2007
Vehicle: '71 Pinto
Location: North Scottsdale, AZ
Posts: 4,000
Mentioned: 13 Post(s)
Quoted: 376 Post(s)
Check f74 @ front prefuse box located passenger interior foot well.
Attached Files
File Type: pdf Front prefuse.pdf (24.8 KB, 33 views)
konigstiger is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > C219 CLS-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome