HELP! - CLS55 AMG Starter Replacement - Fuse Issue? - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-18-2018, 12:27 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2018
Vehicle: 2006 CLS55 AMG
Location: Auburn, CALIFORNIA
Posts: 10
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
HELP! - CLS55 AMG Starter Replacement - Fuse Issue?

Hey there. I am new to these forums but hoping someone can help.
I replaced the starter this week on my '06 CLS55 AMG, including attaching the main 12v feed to it and the other smaller wire to the other screw post terminal and before I could test it out, I believe when re-hooking up the main battery in the trunk I accidentally shorted it. Now, when I turn the key to activate accessories I get no dashboard display but I can hear the air struts working and the headlights do come on.

I checked all the fuses and relays on the left dashboard panel and the panel in engine compartment and the panel right next to the main battery in the trunk. All appear good.

Is there a main fuse that if blown will block all the accessories from working ?

I can't seem to locate the :Rear Prefuse panel - see pic attached. I read that the rear Prefuse panel has some seriously large fuses amp limits, like 150amps so I am thinking this panel might have a major fuse blown.

Any insight is appreciated. Thanks!
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2018-08-18 at 12.27.09 PM.jpg
Views:	30
Size:	65.5 KB
ID:	2448133  
mbrinskele is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-18-2018, 02:56 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2018
Vehicle: 2006 CLS55 AMG
Location: Auburn, CALIFORNIA
Posts: 10
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Folks; I found out that the main battery only was putting out 8volts. I jumped it and the Benz started right up!

Duh! Right!?!

Cheers!
mbrinskele is offline  
post #3 of 3 (permalink) Old 08-19-2018, 09:38 AM
Moderator
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2011 SL550, 2010 ML350 FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
Location: Birmingham, AL
Posts: 18,589
Mentioned: 38 Post(s)
Quoted: 1718 Post(s)
Lifetime Premium Member
Garage
Moved to C219 forum as this is a MY2006 CLS.

--

- RODNEY


So you want to send me a private message? Please read this first:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Stable:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rudeney is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > C219 CLS-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome