Battery drain very huge 3.7A - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-24-2019, 06:57 AM Thread Starter
BenzWorld Junior Member
 
imantr's Avatar
 
Date registered: Apr 2008
Vehicle: CL500 2000
Location: Jakarta
Posts: 37
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
Battery drain very huge 3.7A

Help me. I have tried to search in W220/W215 forum, but has no clue yet.
My car has battery drain overnight. I remove the rear SAM, and measure the drain by connecting the negative terminal with Ampmeter for about 25 minutes, and the current is around 3.7-3.8A. I suspect it coming from Alternator, and check that after measurement, the alternator a little bit warm.
Has anyone here have some experiences how to solve this issue?
Please advise.

Thank a lot !
imantr is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-25-2019, 07:09 AM
BenzWorld Junior Member
 
Date registered: Jan 2019
Posts: 11
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Quote:
Originally Posted by imantr View Post
Help me. I have tried to search in W220/W215 forum, but has no clue yet.
My car has battery drain overnight. I remove the rear SAM, and measure the drain by connecting the negative terminal with Ampmeter for about 25 minutes, and the current is around 3.7-3.8A. I suspect it coming from Alternator, and check that after measurement, the alternator a little bit warm.
Has anyone here have some experiences how to solve this issue?
Please advise.
Autoguysland discuss at four reasons that signify a dying battery. Visit autoguysland website to read more
Thank a lot !
How about the voltage value?? Do you measure it??
harveyspecter1209 is offline  
post #3 of 5 (permalink) Old 07-27-2019, 01:30 AM Thread Starter
BenzWorld Junior Member
 
imantr's Avatar
 
Date registered: Apr 2008
Vehicle: CL500 2000
Location: Jakarta
Posts: 37
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
Quote:
Originally Posted by harveyspecter1209 View Post
Quote:
Originally Posted by imantr View Post
Help me. I have tried to search in W220/W215 forum, but has no clue yet.
My car has battery drain overnight. I remove the rear SAM, and measure the drain by connecting the negative terminal with Ampmeter for about 25 minutes, and the current is around 3.7-3.8A. I suspect it coming from Alternator, and check that after measurement, the alternator a little bit warm.
Has anyone here have some experiences how to solve this issue?
Please advise.
Autoguysland discuss at four reasons that signify a dying battery. Visit autoguysland website to read more
Thank a lot !
How about the voltage value?? Do you measure it??
The voltage after 25 minutes measurement aroind 11-12V
imantr is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 07-30-2019, 02:34 AM
BenzWorld Veteran
 
ifari's Avatar
 
Date registered: Jan 2005
Vehicle: W215-CL500, W208-CLK320, W140-300SE
Location: Ontario, Canada
Posts: 630
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Quote:
Originally Posted by imantr View Post
Help me. I have tried to search in W220/W215 forum, but has no clue yet.
My car has battery drain overnight. I remove the rear SAM, and measure the drain by connecting the negative terminal with Ampmeter for about 25 minutes, and the current is around 3.7-3.8A. I suspect it coming from Alternator, and check that after measurement, the alternator a little bit warm.
Has anyone here have some experiences how to solve this issue?
Please advise.

Thank a lot !
Eject your Nav disc and then see what happens to the draw. If it goes down, that is the source of your problem.
ifari is offline  
post #5 of 5 (permalink) Old 07-31-2019, 07:53 AM Thread Starter
BenzWorld Junior Member
 
imantr's Avatar
 
Date registered: Apr 2008
Vehicle: CL500 2000
Location: Jakarta
Posts: 37
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
(Thread Starter)
Quote:
Originally Posted by ifari View Post
Eject your Nav disc and then see what happens to the draw. If it goes down, that is the source of your problem.
Thanks for your advice. I disconnected the navigation unit, but still draining.
imantr is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > C215 CL-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome