Steering is difficult at low speeds after a U turn - Page 2 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 33 (permalink) Old 06-11-2019, 05:30 AM Thread Starter
BenzWorld Member
 
Blackduc1's Avatar
 
Date registered: Mar 2013
Vehicle: 2009 CLK350 COUPE
Location: Pennsylvania, USA
Posts: 184
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
(Thread Starter)
I am installing the new pump tonight, and I will let you know how it goes. Auto Parts Intl. kept ordering the wrong part, so I went with your suggestion Rodney.

Great price, quick shipping.

This is not a fun job!

2009 CLK 350 Coupe

2003 Lexus LS 430 Sold!!
(referred to as the Silver Mistake)

2005 E500 Estate - Sold

2004 E320 Estate - Sold

1998 E320 - Sold
Blackduc1 is offline  
Sponsored Links
Advertisement
 
post #12 of 33 (permalink) Old 06-11-2019, 03:34 PM
Moderator
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2011 SL550, 2010 ML350 FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
Location: Birmingham, AL
Posts: 18,474
Mentioned: 37 Post(s)
Quoted: 1692 Post(s)
Lifetime Premium Member
Garage
I've always had good experiences with mercedespartsdelivered.com. It's the online parts store for Mercedes-Benz of Naples, FL. They seem to always have the lowest price , esp. after adding shipping.

--

- RODNEY


So you want to send me a private message? Please read this first:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Stable:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rudeney is online now  
post #13 of 33 (permalink) Old 06-13-2019, 08:49 AM Thread Starter
BenzWorld Member
 
Blackduc1's Avatar
 
Date registered: Mar 2013
Vehicle: 2009 CLK350 COUPE
Location: Pennsylvania, USA
Posts: 184
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
(Thread Starter)
Ok, this is truly unbelievable... The part sent from FL was also wrong, and after an exhaustive search and a call to MBZ NA... this part is NO LONGER AVAILABLE!!!!

2009 vehicle, and they no longer offer a replacement power steering pump for this car. The best I was told is that it might be available sometime in September or October. Which does me no good at all. Then the dealer tried to charge me a 15% restock fee on a part that does not exist.

I am no forced to purchase a used part on fleabay and hope for the best. I am beyond annoyed this time. I have driven these cars for a very long time and this is my last Mercedes Benz.

If you have a 2009 CLK 350 Coupe with a sport package, and you need a power steering pump, I wish you the best of luck. The exact words from Mercedes were, "we no longer offer that part for your car. We are very sorry for your inconvenience." I can't trade or sell a car that doesn't steer...

I'm done.

2009 CLK 350 Coupe

2003 Lexus LS 430 Sold!!
(referred to as the Silver Mistake)

2005 E500 Estate - Sold

2004 E320 Estate - Sold

1998 E320 - Sold
Blackduc1 is offline  
Sponsored Links
Advertisement
 
post #14 of 33 (permalink) Old 06-13-2019, 04:03 PM
BenzWorld Member
 
Date registered: Dec 2016
Vehicle: 2009 CLK 350
Location: Stow, MA, USA
Posts: 80
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
You are being a bit dramatic about the issue.

There are lots of CLKs being parted so it shouldn't be hard to find a decent used power steering pump.

Cheer up!
Anker is offline  
post #15 of 33 (permalink) Old 06-13-2019, 06:51 PM Thread Starter
BenzWorld Member
 
Blackduc1's Avatar
 
Date registered: Mar 2013
Vehicle: 2009 CLK350 COUPE
Location: Pennsylvania, USA
Posts: 184
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
(Thread Starter)
You’re right. My apologies.

2009 CLK 350 Coupe

2003 Lexus LS 430 Sold!!
(referred to as the Silver Mistake)

2005 E500 Estate - Sold

2004 E320 Estate - Sold

1998 E320 - Sold
Blackduc1 is offline  
post #16 of 33 (permalink) Old 06-13-2019, 09:10 PM
Moderator
 
rudeney's Avatar
 
Date registered: Dec 2004
Vehicle: CURRENT: 2011 SL550, 2010 ML350 FORMER: 2007 CLK550 Cabriolet, 2002 C240, 2001 ML320, 1984 300TD
Location: Birmingham, AL
Posts: 18,474
Mentioned: 37 Post(s)
Quoted: 1692 Post(s)
Lifetime Premium Member
Garage
So, what's different about the wrong pump? I wonder if it can be adapted to fit?

--

- RODNEY


So you want to send me a private message? Please read this first:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


My Stable:


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rudeney is online now  
post #17 of 33 (permalink) Old 06-14-2019, 03:25 AM
BenzWorld Elite
 
Benzyle's Avatar
 
Date registered: Nov 2013
Vehicle: MY05 CLK55 AMG , MY05 CLK320,Former,C180 Kompressor,Jensen Healey,Ford Capri V6,Alfa GTV.
Location: Australia's East Coast
Posts: 1,396
Mentioned: 2 Post(s)
Quoted: 298 Post(s)
I would fit a used but guaranteed part,,,when you fit it , be sure to change all the fluid in the system with new , check whether you need yellow or green fluid and buy approved fluid to match ,,,,that way your new pump should last for many years.
Blackduc1 likes this.
Benzyle is offline  
post #18 of 33 (permalink) Old 06-14-2019, 05:37 AM Thread Starter
BenzWorld Member
 
Blackduc1's Avatar
 
Date registered: Mar 2013
Vehicle: 2009 CLK350 COUPE
Location: Pennsylvania, USA
Posts: 184
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
(Thread Starter)
The wrong pumps are just slightly different faces and they will not line up perfectly, which makes them leak. I supplied VIN #'s and part #'s, yet they are still wrong.

Used pump going on today, and all fluid will be replaced with the correct fluid. MBZ wanted $53 per quart for fluid that is readily available for $14-$16 per quart.

I only hope this process will benefit others when you have to replace a power steering pump.

If your power steering pump fails and has part number 005 466 5701, it is no longer available from MBZ. You will have to source from a junkyard.

2009 CLK 350 Coupe

2003 Lexus LS 430 Sold!!
(referred to as the Silver Mistake)

2005 E500 Estate - Sold

2004 E320 Estate - Sold

1998 E320 - Sold
Blackduc1 is offline  
post #19 of 33 (permalink) Old 06-17-2019, 07:00 AM Thread Starter
BenzWorld Member
 
Blackduc1's Avatar
 
Date registered: Mar 2013
Vehicle: 2009 CLK350 COUPE
Location: Pennsylvania, USA
Posts: 184
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
(Thread Starter)
Used part fitted, and entire system flushed and replaced with new fluid. New serpentine belt, sway bar links and several other suspension components and all seems to be working well.

I'm not thrilled putting used parts on a car that is 10 years old, but in this case, I had no choice.

My apologies again for letting this process get the best of me; it was just frustrating to have a simple part change turn into a 2+ week project, and I vented on the Forum. Won't happen again.

Thanks for all the help, especially Rodney. I am sending my old pump out to be rebuilt so I will have a spare should I ever need one, or if someone here runs into the same problem and needs a pump, I can help out.

Best,

Rick
rudeney likes this.

2009 CLK 350 Coupe

2003 Lexus LS 430 Sold!!
(referred to as the Silver Mistake)

2005 E500 Estate - Sold

2004 E320 Estate - Sold

1998 E320 - Sold
Blackduc1 is offline  
post #20 of 33 (permalink) Old 06-20-2019, 01:27 PM Thread Starter
BenzWorld Member
 
Blackduc1's Avatar
 
Date registered: Mar 2013
Vehicle: 2009 CLK350 COUPE
Location: Pennsylvania, USA
Posts: 184
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
(Thread Starter)
Hello All!

Well, as I wrote above, I installed the used pump, flushed the system with the correct fluid, changed the serpentine belt, and everything seemed to be back to normal.

Until this morning. After the car sat in the garage overnight, I jumped in this morning to go to work and the problem is back. The pump does not squeal, or make any noises, it just acts like I have no power steering at low speeds (<10 MPH).

I am open to any ideas or things to try, but now I am suspecting the steering rack. Other than leaking, is there a way to diagnose a bad steering rack?
Could it be that the used power steering pump is bad?

The first thing I will check is the fluid level and make sure I have no air trapped in the system.

Any input would be helpful. Again, this problem originated after making a tight U Turn on the highway.

Thank you!

Rick (blackduc1)

2009 CLK 350 Coupe

2003 Lexus LS 430 Sold!!
(referred to as the Silver Mistake)

2005 E500 Estate - Sold

2004 E320 Estate - Sold

1998 E320 - Sold
Blackduc1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Coupe/Convertible Forums > C209/A209 CLK-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome