Mercedes-Benz Forum - View Profile: Star follower

Star follower Star follower is offline

BenzWorld Member

  About Me

  • About Star follower
    Location
    Palmerston North New Zealand
    Vehicle
    1970 w109 6.3, 2014 ML350 (petrol) AMG kitted, 2004 Vito 115 crewbus, 2003 CL600 V12 bi-turbo
    Biography
    Silver Star award recipient for 2012, National MB Club President for New Zealand
    Interests
    Mercedes-Benz, F1
    Occupation
    semi retired engineer

  Statistics

Total Posts
General Information
  • Last Activity: 06-18-2019 05:06 PM
  • Date registered: 03-04-2007
  • Referrals: 0

  Contact Info

Instant Messaging
Send an Instant Message to Star follower Using...
This Page
https://www.benzworld.org/forums/92376-star-follower.html

  Mentions

No results to display...

  Quotes

05-27-2019
11:02 AM - as.thompson quoted Star follower in post Sticky mess on switches
Sticky mess on switches. I have tr...
05-18-2019
08:45 PM - mattml430 quoted Star follower in post New windscreen - lane assist no longer works
Yes it does - are the lines on you...
05:19 PM - Star follower quoted mattml430 in post New windscreen - lane assist no longer works
I know mine has 2 lines across...
11-08-2018
07:53 PM - calgary quoted Star follower in post CL500 Drivers Soft-close and Mirror Turn Signal
Hi - I had a 'ton' of things not w...
03-31-2018
04:00 PM - Das_ist_gut quoted Star follower in post Coil pack supplier please
I need to buy a coil pack. Can som...
02-22-2018
10:13 AM - GregW / Oregon quoted Star follower in post 2014 ML350 petrol
Hi - I have just purchased a 2014 ...
09-20-2017
05:55 PM - Sbest6983 quoted Star follower in post Accelerator pedal sensor
I am pretty sure my accelerator pe...
09-18-2017
10:15 AM - Dave2302 quoted Star follower in post Next to no accelerator response on V12TT
I think you are right - I looked u...
04:19 AM - Star follower quoted tusabes in post Next to no accelerator response on V12TT
Bad pedal I think you are...
09-17-2017
09:14 PM - Star follower quoted tusabes in post Next to no accelerator response on V12TT
Was it fine before the plug ...
07-12-2017
04:02 PM - Star follower quoted sparkydude in post New windscreen - radio now poor
There is a popper type fixing l...
05-17-2017
02:08 AM - Star follower quoted Fun2BClean in post 2002 CL 600 Key Fob Not Working - HELP!!
Hey there, I get it but yes, I...
04-17-2017
12:30 AM - pancholi quoted Star follower in post Multiple Leaky ABC Hoses
I have a 2003 CL600TT and have had...
09-26-2016
03:28 AM - Star follower quoted pinkster in post Trouble with key
Is it just the 1 key of both?...
09-04-2016
06:08 AM - keyhole quoted Star follower in post Self closing rear window failure
Hi - I have just discovered my re...
07-10-2016
07:21 AM - reward52 quoted Star follower in post 2004 S430 COMAND SCREEN STOPPED WORKING
Did you have a flat battery prior ...
02-03-2016
12:38 PM - Dr Matt quoted Star follower in post Short drag video of my CL65
love watching your drags - any mor...
12-28-2015
02:09 AM - Star follower quoted Dr Matt in post Short drag video of my CL65
Thanks guys. And the CL65 we...
05-25-2015
03:14 AM - Star follower quoted Interceptor1 in post W215 Picture Gallery - Show us your CL!
Hello all, I have modified my...
05-03-2015
09:20 AM - keyhole quoted Star follower in post Is there a engine cooling fan fuse?
Hi All - before I embark on what c...
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome