Mercedes-Benz Forum - View Single Post - Version II HVAC problem
View Single Post
post #2 of (permalink) Old 06-26-2019, 08:38 AM
okyoureabeast
BenzWorld Elite
 
okyoureabeast's Avatar
 
Date registered: Mar 2017
Vehicle: 1984 380SL
Location: North America
Posts: 2,006
Mentioned: 6 Post(s)
Quoted: 676 Post(s)
Edit: Ok I had some more time to re-read your wall of text. For the future, paragraphs please.

Assuming your profile is correct (a 5 speed euro 280SL) and from from that picture, you have ACC1. IE the one with manual controls.

ACC2 is the dreaded Chrysler servo that leaks everywhere. My 380SL has ACC3 and everyone who has a post 1986+ vehicle has ACC4.

ASSuming what I have written above, your mechanic was making a wild ass guess and frankly at the prices they're quoting you an expensive one that might be incorrect.

Now I may be wrong. Does your climate control look like the one you posted in the image above or does it look like this?




(Ignore this bottom bit because I think you have version 1)

Contact this guy http://www.cruisecontrolrepair.com

Forum guy by the name of JamesDean. He repairs these old boards . Most likely a bad solder joint and or a bad capacitor, all of which he will fix and replace.

You will need to remove every component of the system and mail it to him . I think it took him a week to fix and mail back. Great prices and you get to keep your ad units.
okyoureabeast is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome