Mercedes-Benz Forum - View Single Post - 2011 ML350 Bluetec
View Single Post
post #16 of (permalink) Old 06-11-2019, 11:11 PM
autoarcheologist
BenzWorld Member
 
Date registered: Nov 2015
Vehicle: 2010 Mercedes Ml350 Bluetec
Location: Portland, OR
Posts: 83
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
I didn't do nearly enough research before buying ours. But after about a year we really like it.

Part of the reason I bought it was because it was a company car and had regular maintenance as documented by Carfax.

The original owner had to replace the oil cooler seals twice! But they seem to be holding up OK now.

I had a fuel leak which turned out to just be a pinched o ring on an injector. And a DEF leak, which was also a missing O-ring. I don't have a record of someone replacing the DEF heater, but it appears it was replaced and someone forgot an oring.

At 140k miles I do have a slight timing chain rattle when cold, but always assumed that was normal. I will look into that more.

I also had to fix the ignition switch, which took an hour and was just bad solder joints.

Overall my wife loves it, and it tows our vintage trailer very well. I am changing the oil closer to 5-6k miles and looking into different oils for it. I also plan to add an oil catch can to it.

I do most of my own work and I think the front suspension will need attention soon. I wouldn't buy it if I was paying for most service. And if we didn't need the torque for towing I would just get a 350 gas. We had an e350 wagon which was also pretty reliable.

Sent from my ONEPLUS A3000 using Tapatalk
autoarcheologist is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome