Mercedes-Benz Forum - View Single Post - New Owner: Hello, Thank You and Intro Maintenance Advice
View Single Post
post #8 of (permalink) Old 06-11-2019, 02:14 PM Thread Starter
nyteryda3
BenzWorld Junior Member
 
Date registered: Sep 2007
Vehicle: 2003 CLK500
Location: USA - Orange County, CA
Posts: 5
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Quote:
Originally Posted by keyhole View Post
Welcome to the forum.

If it IS a factory-fitted Valeo and it has lasted 100k miles, I would leave it alone. If it was going to fail, it would have failed a long time ago!
Quote:
Originally Posted by Benzyle View Post
Valeo radiators in cars built after Sept, 2003 are revised and are ok ,,, but if before that ,,,maybe ,,,but like Keyhole said ,,save yourself $600 ,,,
and if there is no record of a new crank position sensor having been fitted in the past ,,then spend some of that $600 on a new one ,, ,,,replace it with a new Bosch ..
they all seem to fail at some point and will leave you stranded when it does.
Replace it and you will be good for at least 12 years.
Nice car ,,,enjoy !
Thank you both for the advice. I got the Service A done today, the mechanic advised against changing the radiator as you both said so spot on!

He did also advise against doing the transmission service at this point.

He did a fairly thorough inspection and test drive of the car, ran the Xentry DAS with me (all clear) so I was pretty satisfied at that point but I will inquire about the CPS that Benzyle recommended as there is no record of that being replaced in the past.
nyteryda3 is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome