Mercedes-Benz Forum - View Single Post - Overheat/Aux Fans/AC Issues
View Single Post
post #3 of (permalink) Old 05-22-2019, 08:24 AM Thread Starter
maranelloboy05
BenzWorld Member
 
Date registered: Jul 2018
Vehicle: 1989 190e 2.6
Location: Alexandria, VA
Posts: 110
Mentioned: 0 Post(s)
Quoted: 29 Post(s)
Garage
(Thread Starter)
Quote:
Originally Posted by dolucasi View Post
Lots of questions there to address.

(1) Is it normal to hit 102c idling at 90F outdoor temp without AC operating?

- Yes on a 30 year old car. Sometimes people blame the regular fan clutch for not operating properly, sometimes radiator is blamed for not allowing enough coolant flow at idle, etc.
- If I were you I would just lower your electric fan trip temperature to be something like 95c. You can add a 1.2K ohm resistor in parallel to the temp sensor on the cylinder head. Works pretty well.

(2) AC refrigerant leak.

- Is yours converted to R134 or is it still R12?
- In either case check your high pressure house for wetness. If it is wet, read my post on the matter for a quick fix that will only cost you $10. Mine has stopped leaking with that temporary fix.
Everything seems to be operating correctly aside from the aux fan low speed. I did see where you can simply buy a lower temp sensor so might try that.

Converted to r134 at some point. When I bought the car last summer there was some AC, after winter I had nothing and after a can of refrig. its "working" again. Found what looked to be refrig. on the plastic panel under the engine so assuming there's a leak there somewhere.
maranelloboy05 is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome