Mercedes-Benz Forum - View Single Post - ASR/ABS Lights
View Single Post
post #15 of (permalink) Old 04-22-2019, 08:27 AM
Brett Humphrys
BenzWorld Junior Member
 
Date registered: Jan 2018
Vehicle: 1995 SL320, 40K miles, 1995 SL320, 86K miles, 1995 SL500 98K miles, 1982 300SD
Location: Knoxville, Tennessee
Posts: 14
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Looking for advice regarding ABS ASR lights that came on with my '95 SL500. I've read through all the threads on this topic I believe and still struggling to fix.

Symptoms: both lights on, speedometer bouncy. Otherwise car performance is fine. With 32 pin diagnostic connector, pin 6 has 3 flashes. (My diagnostic book is giving me conflicting info: one page says "left VSS sensor open circuit" and another page says "right VSS sensor open circuit" for this fault depending on model year but both list 1995).

Attempted fixes:
Battery voltage: 12.5V car off, 14.1V car on
Cleaned drivers side front speed sensor. Even swapped it with one from my SL320.
Cleaned passenger side front speed sensor (this one looked different - the surface was flat/didn't have the metal piece protruding out)
Cleaned drivers side rear speed sensor.
Replaced engine wiring harness (had this anyway and had been putting off the task).
Checked the 10 amp fuses in control module compartment

My next steps (in this order):
1) swap passenger side speed sensor with one from my SL320.
2) swap control modules with ones from my SL320

Am I missing something or any other suggestions? Fortunately I have the ability to "swap parts" before buying anything. Thank you for your help.
Brett Humphrys is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome