Mercedes-Benz Forum - View Single Post - W164 ML63 Air suspension question
View Single Post
post #1 of (permalink) Old 04-16-2019, 05:02 AM Thread Starter
mixja23
BenzWorld Junior Member
 
Date registered: Mar 2019
Vehicle: 2007 ML63
Location: Qatar
Posts: 44
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
W164 ML63 Air suspension question

So, bit of a weird one... Every now and then, say 3-4 days, I'll leave the car parked up for around 1-2 hours, when I go back to it, one, sometimes both, the front springs have dropped to the floor... Soon as I open the door tho, car pumps itself up to correct height, this without starting the engine... Initially it was just the passenger side which lead me to believe it may be the air spring but more often than not now, it drops on both sides which would suggest not the springs... I cant hear any leaking from either side either before I open the door or after when it pumps itself back up, there's no errors showing up on Carly or the dashboard either and when car is driving, it's as it should be...
Anyone had this before please...?? If so, what was the cause...??
Thanking you kindly...
Attached Thumbnails
Click image for larger version

Name:	IMG_5631.jpg
Views:	9
Size:	72.6 KB
ID:	2504838   Click image for larger version

Name:	IMG_5632.jpg
Views:	10
Size:	68.2 KB
ID:	2504840   Click image for larger version

Name:	IMG_5633.jpg
Views:	10
Size:	73.8 KB
ID:	2504842   Click image for larger version

Name:	IMG_5634.jpg
Views:	9
Size:	60.5 KB
ID:	2504844  
mixja23 is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome