Mercedes-Benz Forum - View Single Post - S500 Resurrection, Dave's Thread
View Single Post
post #452 of (permalink) Old 03-31-2019, 11:41 PM Thread Starter
Dave2302
Moderator
 
Dave2302's Avatar
 
Date registered: Nov 2013
Vehicle: V220 Ambiente S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Location: NW Scotland Near Eilean Donan Castle
Posts: 5,371
Mentioned: 81 Post(s)
Quoted: 762 Post(s)
Lifetime Premium Member
(Thread Starter)
Hi @Deplore ,

Yeah, I know what you mean, if that were a Customer I'd have bought a good used with 3 month G/Tee, well, that is exactly what I did with that CL a while back.

I have put the "Donor PSE" back together and back in the loft, in case I need any more spares from it, the Vac Pump out of mine is still good, it's just the Motor that's lazy, doesn't look burned, like you said earlier one day I might find a suitable set of brushes for it if push comes to shove

I was looking on fleabay yesterday, found a really nice W220, bit scabby round the body, 2001 V8 S500, fully loaded, has had brand new Bosch Battery and 4 brand new struts and a compressor, not long been stopped using it, guy started it at 1000 some weeks ago, now down to 650 ..............................

1 problem, it's 600 miles away from me in London

If it's still there in a couple weeks I'll probably be on a plane and fly down there, just can't take 2 days off right now

Chow for now,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dave2302 is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome