Mercedes-Benz Forum - View Single Post - Slight idle vibration (intermittent)
View Single Post
post #1 of (permalink) Old 02-13-2019, 04:03 PM Thread Starter
oliverp
BenzWorld Member
 
Date registered: Jan 2018
Vehicle: '04 S500 4Matic
Location: Toronto, Canada
Posts: 303
Mentioned: 4 Post(s)
Quoted: 44 Post(s)
(Thread Starter)
Slight idle vibration (intermittent)

Hi Everyone

Ever since I bought the car a year ago, I have had an issue with an intermittent vibration. Sometimes it's when the engine is cold (I can feel it through the seat, and the door shakes if it's open - this is even in Park). Sometimes it's when the engine is warm at a stop light. Shifting from D to N seems to reduce it a bit. Sometimes it doesn't happen at all for days at a time. It doesn't correlate to engine or ambient temperature.

Initially I was going to replace the engine and trans mounts but the mechanic says they look fine and are fairly new. Also, with it being intermittent, I didn't think it could be the mounts. If they were bad I would expect it to be more constant.

On Friday I am replacing the spark plugs, spark plug wires, air filter and I am also getting the mass air flow sensor and throttle body cleaned.

I was wondering if anyone can think of any other maintenance activities to do while I am at it? I have a new CPS that I keep in the trunk just in case but I wasn't sure if I should fit this until I need to. I have SDS and there are no errors or codes. I am hoping that it's an issue with the plugs or wires that isn't serious enough to generate a code, but is serious enough for me to feel it.

Thanks
Ollie

(2004 S500 4Matic, 190,000Km, Toronto, Canada)
oliverp is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome