Mercedes-Benz Forum - View Single Post - a/c issues
Topic: a/c issues
View Single Post
post #1 of (permalink) Old 05-13-2018, 07:27 PM Thread Starter
clb0099
BenzWorld Member
 
clb0099's Avatar
 
Date registered: Nov 2003
Vehicle: 2007 Mercedes S550 2008 Mercedes x164, 2007 Mercedes w164, 2001 Mercedes W210 E55 AMG
Location: nj
Posts: 367
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Send a message via AIM to clb0099
(Thread Starter)
a/c issues

So last year I bought a 2001 mercedes E55 amg and the ac wasn't working correctly. Since that bought I have put in a new compressor, expansion valves, blower motor, and also blower resistor. These were all professionally installed by a German Mechanic. Last summer the ac worked fine and had absolutely no issues. Well this march we had a few hot days and I went to turn on the ac and of course it started blowing hot air. I drove to my mechanic and he tested the ac and saw the Freon was correct level roughly 2.2 pounds. While he vacuumed the Freon out and put back in he said to me to see if the ac had gotten colder which is didn't. He suggestion to me was that I might have to do a clutch on the fan or replace the auxiliary fans that blow on the condenser. I ordered the fan clutch and also the auxiliary dual fans as well as the spools tool to do the fan clutch. While waiting for the parts I was still driving the car on a daily basis and noticed that the ac got ice cold on one of the days that it was 73 degrees out. I also noticed that the value of the Freon on the climate live data was 18 which I believe is 1.8. The normal level that I have seen is between 6-11 on my climate control. After a few miles of driving I noticed that the 18 dropped down to a 6-7 and the ac started to blow hot air. As with all my other cars is usually the opposite when driving faster. The ac usually blows colder air at on higher speeds of driving. So after reading James's post I decided today to put the live date values from my climate control with the heat on and then with the ac on. Below are the valves I got. Also want to add that my heat works fine but I am about to put a new duo-valve in for preemptive maintenance and also it was a suggestion my mechanic. One last thing I have noticed also that the engine temperature is above 80 Celsius its close to 83-84ish no matter the temperature outside. I did notice the ac worked better when the engine temperature was below 80 Celsius on those few days it actually worked. So onto to the climate control live data values

Heat on : Ac on

1-96 1-87
2-73 2-80
3-154 3-114
4-154 4-127
5-93 5-94
6-179 6-184
7-0.5 7-0.8
8-69 8-75
9-3.3 9-40
10-6.0 10-2.7
11-3.6 11-3.4
12-4.3 12-4.3
20-3.2 20-3.2
21-42 21-42
22-00 22-00
23-211 23-211
24-13.3 24-13.1
40-164 40-164
41-91 41-91
42-72 42-72
43-136 43-136


I would like to add I too did not replace the drier but the ac was working fine last year so I nor my mechanic feel that a new drier is needed. any help would be appreciated
clb0099 is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome