Mercedes-Benz Forum - View Single Post - c32 amg - p0410
View Single Post
post #3 of (permalink) Old 05-12-2018, 09:36 AM Thread Starter
w220dad
BenzWorld Junior Member
 
Date registered: Jul 2016
Vehicle: 2003 S500, 2002 C32 AMG
Location: Texas
Posts: 28
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
(Thread Starter)
Quote:
Originally Posted by Brian K View Post
Pull the egrís, strip them... clean them, new gaskets, hoses. Should look like new, like the old girl deserves. Everything should be fine then. O2 sensor just looking for a change when egr is called for.
Where might the EGR valve(s) be located?

Still having the same issue to this day, but have found out more. The inside of the hoses and tubes going from the secondary air pump to the two valve in front of the surge tanks have small amounts of condensation in them. Replaced all of these off of another C32 (which had completely dry inside and looked brand new). Cleared the CEL and drove for a few days until the CEL came back on with the same code, the P0410 secondary air injection system. Looked inside the secondary air injection hose and tube and also the two valves I replaced in front of the surge tanks, and they all had condensation build-up on them. I'm assuming this is also not normal and may have something to do with the P0410 code. Is there some sort of air check valve or exhaust gas valve that would allow condensation into these air tubes? Any help is appreciated as I still have the same problem months later
w220dad is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome