Mercedes-Benz Forum - View Single Post - Mercedes w203 C200k Aftermarket radio install, no power to head unit
View Single Post
post #1 of (permalink) Old 12-10-2017, 12:20 PM Thread Starter
Ashmanfizz
BenzWorld Newbie
 
Date registered: Dec 2017
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Mercedes w203 C200k Aftermarket radio install, no power to head unit

Hi there guys,

Im new to the forum, been reading the posts for a few months now so thought i would join .

I found out something that may help someone else so thought i would share as i spent hours upon hours researching this issue when deciding to install my aftermarket radio to my C200k 2005.

1. When installing an aftermarket radio you will need a harness.

2. With the Merc i noticed so late on in the install that the radio has no switched power. This meant all you have to do is pull out the compartment where the cigarette lighter is, splice into the bown/yellow cable, then run this cable to the red cable from your new radios wiring harness. This will signal to the radio to switch the radio on when the car goes on.

3. THE BIGGEST POSSIBLE PROBLEM YOU MAY FACE. Sometimes during an aftermarket radio install you may find that you have no power to the radio unit. I then decided to try to plug back in the orginal radio, and and still no power.

I scratched my head for hours, with no possible solutions found on the web, with everyone saying back to the dealer you go. So myself and my dad decided to go through all the fuses. Number 64 under the bonnet and number 36 by the drivers door was the usual suspects, however these fuses where in tact (NOTE these fuses are for the radio). We thenndecided to check the anti theft alarm fuses as we though they may be triggering the car to think the radio has been stolen. These fuses where 8,9,4 and 1. However all these fuses where in tact.

After deciding to check every fuse we came across one fuse which had blown, and this was number 44. Which happened to be labelled as (telephone system). Once replaced this activated power to the radio, and i was able to continue woth the install.

So remember, not only check the radio fuses (#36 and #64) but also check fuses relating to the telephone system which are (#13,#16,#40,#44,#60)

Hope this helps guys, i was forever looking for help for this and could not find anything.

I also have the fuse layout if anyone is looking for it.

Thanks Guys
Ashmanfizz is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome