Mercedes-Benz Forum - View Single Post - Broke fuel line 02ML500 to fuel tank
View Single Post
post #1 of (permalink) Old 11-06-2017, 09:45 AM Thread Starter
bossjj98
BenzWorld Veteran
 
Date registered: Dec 2011
Vehicle: (W163) 2005 ML 350 2002 ML 500 1999 ML 430 1998 ML 320
Location: Holyoke, MA
Posts: 650
Mentioned: 1 Post(s)
Quoted: 77 Post(s)
(Thread Starter)
Broke fuel line 02ML500 to fuel tank

Hi I have a problem on my 02 ML 500 where it won't start and I'm getting 0 fuel pressure, I checked all fuses and they were fine so I decided to change the fuel pump and filter, I have the new pump installed and I am trying to install the new lines, I purchased the three lines required (2 from pump to filter) and one loop line to the fuel feed but I don't have that setup as this is an 02 ML, while disconnecting the old fuel filter I broke the third line and kept pulling at it more because I thought it would eventually come off and I would find a spot to connect the loop line. Now I am almost at the point where there seems to be a metal valve (like a tire valve) of some sort where the fuel feed (loop) line would be coming from on a 98 ml and I read some posts saying that this line runs all the way to the engine and is a costly fix. Would I be able to get some fuel line and clamp it on both sides to the filter and where the loop line would attach? The connector would not budge at all and I don't think my fuel filter has ever been changed as many of these bolts broke in the process of trying to take them off. Even if I could've taken it off at the fuel filter and reattached it to the new one it just seemed that it was so worn out that it needed to be replaced. Any help is greatly appreciated. I hope there is a way of being able to fix this without replacing that entire line.
bossjj98 is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome