Mercedes-Benz Forum - View Single Post - M103 Rough idle and vacuum leak
View Single Post
post #1 of (permalink) Old 09-07-2015, 05:59 PM Thread Starter
codycool55
BenzWorld Member
 
Date registered: Jun 2013
Vehicle: '89 300 SE
Location: Eastern Washington state
Posts: 67
Mentioned: 4 Post(s)
Quoted: 45 Post(s)
(Thread Starter)
M103 Rough idle and vacuum leak

My 89 300 SE with 262k miles has developed a rough idle. When warmed up it idles at around 550-600 rpm. The engine seems to be hunting as the idle will go very slightly up and down. Occasionally when coasting my engine will speed up and stay there for a few seconds before returning to normal speed. I need to depress the gas pedal to start the car, which I understand should be unnecessary. After starting, If I don't keep my foot in the gas for a few seconds the engine will usually die immediately but after restarting will usually stay running without depressing the gas pedal.

About 6 months ago I replaced the fuel filter and spark plugs due to the engine failing to start. Around 3 months ago I replaced the fuel pump relay due to the engine dying and failing to restart. I replaced the o2 sensor about 6 weeks ago after reading the check engine light codes.

I have tested the OVP, ICU, ICV, coolant temperature sensors, air flow sensor plate, throttle position sensor, and a variety of other components ( been working on it a while and I don't remember all I've tested) which have all tested to be working.

The economy gauge does not peg to the left (in the black) when warmed up and idling in drive with the AC off which I understand indicates a vaccuum leak. Using WD-40 I diagnosed a leak in an injector seal and replaced all 6 injector-to-housing seals. The car runs better now, but is not running perfectly. The economy guage still does not peg to the left, so I believe there is still a vacuum leak.

Before replacing the seals I would occasionally get a knocking sound in the engine while idling, but since replacing them about a week ago I have not heard it.

I suspect that the vacuum leak is not my only problem but likely is the largest problem. When testing for leaks I followed this wiki and did not find any other leaks. What are other locations in the vacuum that are likely to leak? I've searched the forum for a diagram but haven't found one for my chassis and engine, does anyone have a diagram?

Any information about a vacuum leak or other problems I have described will be greatly appreciated

Thank you,
Codycool55
codycool55 is offline  
 
 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome