Mercedes Sprinter 211 CDI 2002: Sprintshift runs randomly - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-16-2013, 04:13 PM
BenzWorld Newbie
 
Date registered: Nov 2013
Vehicle: Mercedes Sprinter
Location: Belgium
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Mercedes Sprinter 211 CDI 2002: Sprintshift runs randomly

Hi,

My father got a problem with the gearbox from his Sprinter.

He work as mechanic for years but does not know many thing about this technology.

The gearbox randomly stop running as an automatic gearbox and goes on manual mode. Sometime this happen when driving or sometime just when he starts the truck, that's realy random. The gearbox also stay sometime locked on the 3rd speed. We think that's a kind of security mode to get to a garage. Isn't it?

His first though is that the injectors need to be changed but that cost a lot of money so he would be sure about that before doing this. That's why I ask you some help

(Sorry if I did some fail in my english but I'm from Belgium and don't handle this realy well)

Thanks for future help

Julien
Nieluj is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-14-2014, 05:11 PM
BenzWorld Member
 
DBTRANSPORT's Avatar
 
Date registered: Dec 2006
Vehicle: 316cdi 2002 and 319cdi 2009
Location: St Ives Cambs
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
First of it will have nothing to do with the engine injectors. You need to get the fault codes read this will give you a start. I had a very similar problem years ago with my 02 316 sprintshift that turned out to be a faulty hydraulic pump motor caused by a faulty voltage regulator. The pump motor is fairly easy to replace as its on the side of the gearbox and the regulator is under the drivers seat (or at least it was on a RHD that I had). The gearbox has its own ecu and various sensors if anything is wrong then it goes into a kinda limp mode.
DBTRANSPORT is offline  
#3 (permalink) Old 01-26-2014, 02:07 AM
BenzWorld Junior Member
 
Date registered: Jan 2014
Vehicle: 2003 Sprinter 211 CDI
Location: Cluj-Napoca
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation MB Sprinter 211 CDI

My question regards a 2003 Sprinter 211 CDI I bought a month ago. It is a semi automatic which means that when I engage from neutral to automatic it is supposed to display letter A in the cluster. However it only shows first gear. I tried to drive it and I can only shift gears manually since the automatic does not engage. Moreover I can only do this up to the third gear. After this it wont go shift to the 4th , 5th or 6th.
Reverse function shifts clean, the first 3 gears shift clean (manually) also. Any ideas please? It would be great of a help!

All this worked fine till about 2 weeks ago.

Thank you!
sorinvlaicu is offline  
#4 (permalink) Old 05-08-2014, 03:21 PM
BenzWorld Newbie
 
Date registered: May 2014
Vehicle: 2005
Location: london
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sounds like the Clutch travel sender (G162) has failed which causes the following:

• Gearbox emergency mode will be activated.
• Gear changes in manual mode are then only possible up to 3rd gear.
• An “F” appears in instrument gear indicator.

See Page 56 of this document: http://www.volkspage.net/technik/ssp/ssp/SSP_372.pdf

Its worth studying this document as it really does explain just about everything that goes wrong with this gearbox.

(Its a VW document, but same sprint shift gearbox was used in both Sprinter & Crafter).
mikeyp69 is offline  
#5 (permalink) Old 05-08-2014, 10:46 PM
BenzWorld Junior Member
 
Date registered: Jan 2014
Vehicle: 2003 Sprinter 211 CDI
Location: Cluj-Napoca
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation MB Sprinter 211 cdi

Thank you for the info. Very helpful. Indeed this type of manual I was looking for. I fixed the problem meanwhile.
There is one thing that concerns me: when engine is cold and in the first 5 km the trans shifts good in every gear. Then I feel a little kick between the 2nd and 3rd gear. It increases in intensity up to a point, then keeps shifting like that (from 2nd to 3rd only). All other gears shift fine.


Any hints? Many thanks once again!!!
sorinvlaicu is offline  
#6 (permalink) Old 05-09-2014, 05:45 AM
BenzWorld Newbie
 
Date registered: May 2014
Vehicle: 2005
Location: london
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by sorinvlaicu View Post
Thank you for the info. Very helpful. Indeed this type of manual I was looking for. I fixed the problem meanwhile.
There is one thing that concerns me: when engine is cold and in the first 5 km the trans shifts good in every gear. Then I feel a little kick between the 2nd and 3rd gear. It increases in intensity up to a point, then keeps shifting like that (from 2nd to 3rd only). All other gears shift fine.


Any hints? Many thanks once again!!!
I have no idea, likely because I'm not a mechanic I'm afraid. But I do have a technical mind, which is why I found that VW document very interesting.

I have just experienced the "F" Fault where the engine would not start, resulting in recovery to dealer. This was fixed by the Gear Selector in the cab being replaced. Very odd that something like this would fail. But it is detailed in the VW document.

Was it the Clutch Travel Sender that was faulty in your Sprinter?

ATB
Mike.
mikeyp69 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W901-905 Sprinter


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome