sprinter 2.2 turbo boost questions - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-11-2011, 09:03 AM
BenzWorld Newbie
 
Date registered: Aug 2011
Vehicle: mercedes sprinter 311 lwb 2.2 diesel
Location: cornwall UK
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via Skype™ to mikethebike52
(Thread Starter)
sprinter 2.2 turbo boost questions

i own a 2002 311 sprinter with a 2.2 turbo diesel .. i am experiencing a problem with power at the top end .. no lights are on but after running a while the powers appears to prop a bit and the engine hardly revs over 3k . stop and turn off and the van goes like a dream again ... checked the turbo vacuum and connections all appears ok .. .. i have a small vac hose running from the bottom of the actuator up the bulkhead and hanging down over the engine with a plastic tubular item with an open end facing the engine .. what is this and what does it do ..also i have found a plug under the fuel canister filter going nowhere .. i believe it was originally connected to some sort of sensor attached to the bottom of the filter but cant find a home for it .. could either of these item cause my running problems .. or any ideas greatly appreciated ..
mikethebike52 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-12-2011, 10:58 AM
BenzWorld Junior Member
 
Date registered: Jul 2010
Vehicle: sprinter 311 cdi
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi sounds like your van is going into limp mode. this can be caused by a few different things. please read my recent post on limp mode and loss of power solution this is how i have cured mine. But be warned this is not always the cure.
the wiring to the fuel filter is probably for the sensor that detects water in fuel. the filter should have a plastic unit in the bottom were this plugs in unless a filter has been found with out this. It shouldnt make any difference anyway mine has never been plugged in.
I think the pipe that over hangs the engine if i understand you corectly runs from the boost control valve that sits behind the drivers side headlamp and inturn conects to the actuator on the turbo uncertain what this pipe does but mine looks to have some sort of little filter conected to the end. I do know that the boost control valve can cause limp mode and so i am told by a merc dealer is a common cause. but Bruce who posts on this site a lot and is very up on all things sprinter says the wiring to this valve can be the cause and i think he sells a kit . look for other posts to do with limp mode solutions
Hope this helps steve
steviep5 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W901-905 Sprinter

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
617 turbo boost instructions please JFreemand1@aol.com W123 E,CE,D,CD,TD,TE Class 2 02-01-2011 09:44 AM
Turbo Boost ridemx413 V-Class 12 05-23-2010 03:50 PM
Turbo boost pressure walsi V-Class 2 03-28-2007 05:13 PM
Turbo Boost Q's 83turbodiesel W123 E,CE,D,CD,TD,TE Class 1 07-23-2006 10:30 PM
Sprinter 412 TD 1997 ECU / Boost question ??!!?? ed_menace W901-905 Sprinter 0 07-12-2005 02:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome