sprinter 2.2 turbo boost questions - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W901-905 Sprinter
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-11-2011, 08:03 AM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Aug 2011
Vehicle: mercedes sprinter 311 lwb 2.2 diesel
Location: cornwall UK
Posts: 1
Send a message via Skype™ to mikethebike52
sprinter 2.2 turbo boost questions

i own a 2002 311 sprinter with a 2.2 turbo diesel .. i am experiencing a problem with power at the top end .. no lights are on but after running a while the powers appears to prop a bit and the engine hardly revs over 3k . stop and turn off and the van goes like a dream again ... checked the turbo vacuum and connections all appears ok .. .. i have a small vac hose running from the bottom of the actuator up the bulkhead and hanging down over the engine with a plastic tubular item with an open end facing the engine .. what is this and what does it do ..also i have found a plug under the fuel canister filter going nowhere .. i believe it was originally connected to some sort of sensor attached to the bottom of the filter but cant find a home for it .. could either of these item cause my running problems .. or any ideas greatly appreciated ..
mikethebike52 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-12-2011, 09:58 AM   #2 (permalink)
BenzWorld Junior Member
 
Date registered: Jul 2010
Vehicle: sprinter 311 cdi
Posts: 13
Hi sounds like your van is going into limp mode. this can be caused by a few different things. please read my recent post on limp mode and loss of power solution this is how i have cured mine. But be warned this is not always the cure.
the wiring to the fuel filter is probably for the sensor that detects water in fuel. the filter should have a plastic unit in the bottom were this plugs in unless a filter has been found with out this. It shouldnt make any difference anyway mine has never been plugged in.
I think the pipe that over hangs the engine if i understand you corectly runs from the boost control valve that sits behind the drivers side headlamp and inturn conects to the actuator on the turbo uncertain what this pipe does but mine looks to have some sort of little filter conected to the end. I do know that the boost control valve can cause limp mode and so i am told by a merc dealer is a common cause. but Bruce who posts on this site a lot and is very up on all things sprinter says the wiring to this valve can be the cause and i think he sells a kit . look for other posts to do with limp mode solutions
Hope this helps steve
steviep5 is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W901-905 Sprinter

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
617 turbo boost instructions please JFreemand1@aol.com W123 E,CE,D,CD,TD,TE Class 2 02-01-2011 08:44 AM
Turbo Boost ridemx413 V-Class 12 05-23-2010 02:50 PM
Turbo boost pressure walsi V-Class 2 03-28-2007 04:13 PM
Turbo Boost Q's 83turbodiesel W123 E,CE,D,CD,TD,TE Class 1 07-23-2006 09:30 PM
Sprinter 412 TD 1997 ECU / Boost question ??!!?? ed_menace W901-905 Sprinter 0 07-12-2005 01:43 PM


All times are GMT -7. The time now is 05:11 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.