Limp Mode 313 CDI Sprinter - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W901-905 Sprinter
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-12-2008, 06:53 PM   #1 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2008
Vehicle: 2000 Sprinter 313 CDI Motorhome Conversion
Location: Adelaide Australia
Posts: 3
Limp Mode 313 CDI Sprinter

Could somebody explain please, what actually happens when the engine goes into Limp Mode?

I am aware that the power output is limited, and the engine cannot rev much above 3000 RPM, but how is this achieved?

Is it something that happens within the fuel system? and if it is, what??

or

Is it something that happens within the turbo boost system? and if it is, what??

Thank You
garrick@internode.on.net is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-21-2008, 07:36 AM   #2 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 4
Hi, Garrick,
Can't help you with this, but I am watching for the replies, as I would like to know the answer to this also.
I guess you are trying to get around the limp mode function (disable it)
Cheers, Rick.

Last edited by rickscott1969; 02-21-2008 at 07:37 AM. Reason: Spelling errors
rickscott1969 is offline   Reply With Quote
Old 03-25-2008, 01:43 PM   #3 (permalink)
BenzWorld Newbie
 
Date registered: Mar 2008
Posts: 4
Have exactly the same issues with a 311 CDI - doing my head in!

If anyone has any suggestions I'd be grateful
etlcnes is offline   Reply With Quote
Old 12-29-2009, 08:58 PM   #4 (permalink)
BenzWorld Newbie
 
Date registered: Dec 2009
Posts: 1
Sprinter fix for limp mode

Quote:
Originally Posted by garrick@internode.on.net View Post
Could somebody explain please, what actually happens when the engine goes into Limp Mode?

I am aware that the power output is limited, and the engine cannot rev much above 3000 RPM, but how is this achieved?

Is it something that happens within the fuel system? and if it is, what??

or

Is it something that happens within the turbo boost system? and if it is, what??

Thank You
Your Sprinter has a broken boost controller wire in the loom under the radiator behind the bumper.
Remove the bumper to expose the loom and inspect the loom under the air conditioner condensor. The condensor rubs through the loom at its mounting points, this breaks the control wire and the horn wire.
The reason your car does not code is that the computer thinks the boost controller is working, it is still sending a signal but the signal does not always make it to the controller thus no vacum is applied to the turbo actuator and no boost develops.
For others reading this reply, if the vehicle is in limp mode the EDC light will activate, if the vehicle has no boost there will be no EDC light if the problem is in the solenoid wiring or in the vacum source to the solenoid as the computer can not see this problem.
doctbill is offline   Reply With Quote
Old 01-04-2010, 12:46 PM   #5 (permalink)
BenzWorld Newbie
 
Date registered: Jan 2010
Posts: 1
Smile what happens in limp home !

what really happens is that your ecu has a code that has some thing to do with performance ..

it could be poor perfomance .. to high boost etc
it could also be in The ssg (gearbox) ecu codes that are perfomance related

and it could be a mechanical problem such as wesgate axel malfunktion
wich will result in low boost and the car goes in limp home (no edc light will show )

what really happens is that the vacum valve under the air filter will shut of the vacum to the turbo and you get no boost


cheers / jimmy
JIGAB is offline   Reply With Quote
Old 01-06-2010, 02:52 AM   #6 (permalink)
BenzWorld Member
 
Star automotive solutions's Avatar
 
Date registered: Mar 2009
Vehicle: TO NAME A FEW Sprinter 313 4x4 ,E320 CDI,A160,A170 CDI ,W123 230,SLK230K, C180 ,C200,C230K, C230K
Location: Norfolk ,UK
Posts: 207
Limp home mode

The ecu detects a fault or wrong value it then changes to a default value enabling you to get home,
__________________
Bruce
Star automotive solutions is offline   Reply With Quote
Old 02-05-2010, 01:10 PM   #7 (permalink)
BenzWorld Newbie
 
Date registered: Apr 2009
Posts: 1
My 2003 Sprinter has a lack of power (seems like the turbo not working), but is driveable if I manually shift it. Does not have it's normal get up & go, but as I said is driveable. Is this what you have experienced too ? I will check the loom as suggested above. Is the bumper an exercise in frustration to remove ?
Thanks in advance for any info
Benzguy4life is offline   Reply With Quote
Old 02-08-2010, 02:53 AM   #8 (permalink)
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: Sprinter
Location: London
Posts: 7
Limp mode - video link

I personally like this explaination:


myvan.com
myvan is offline   Reply With Quote
Old 02-13-2010, 04:19 PM   #9 (permalink)
BenzWorld Newbie
 
Date registered: Feb 2010
Posts: 1
I also experienced what I thought was Limp mode. No power suddenly and inability to rev above 2500. Pull over, turn off and restart and away we go...for a while. Turns out that it was the engine running without any boost. The temperature sensor leading into the turbo was faulty and there was a crack in the big hose it mounts into. Replaced both and now all is good. This also fixed my inability to start on cold mornings without plugging it in. Two birds, one stone. Hope this helps at least one other Sprinter owner someday.
schaene is offline   Reply With Quote
Old 03-06-2010, 03:01 PM   #10 (permalink)
BenzWorld Junior Member
 
Date registered: Jan 2008
Location: London
Posts: 39
Send a message via MSN to williamsdiesels.com
Post williamsdiesels.com

should you ever require a diagnosis, a ball joint removed, a service, or even a reapir, may u not get start error, i will be here for you...........

www.williamsdiesels.com
williamsdiesels.com is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W901-905 Sprinter

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Limp Mode noelchambers R170 SLK Class 4 08-18-2008 01:27 PM
313 CDI Power Loss (Limp Mode) garrick@internode.on.net W901-905 Sprinter 3 04-07-2008 09:54 AM
sprinter 313 cdi wierd fault rosin dubh W901-905 Sprinter 7 04-01-2008 07:31 AM
Looking for a Passengers 15+1 Sprinter 313 CDI near Peru! wayostein For Sale/Wanted/Trade/Giveaway 0 07-28-2007 07:20 AM
HELP!! .. limp mode! BenzSLK230 R170 SLK Class 7 06-12-2006 09:23 AM


All times are GMT -7. The time now is 03:08 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.