MB SPRINTER CDI PROBLEMS? ASK HERE - Page 9 - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#81 (permalink) Old 04-25-2010, 11:17 AM
BenzWorld Junior Member
 
Date registered: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Star automotive solutions View Post
It may have a speed limiter but i doubt it , sounds like another problem, however unless you have your figures wrong it should be limited to around 3000 rpm, visit my site sprintercdi.co.uk

Dont be tempted to start throwin money at it , I have various people arounfd the Uk who I could reccomend who have star diagnosis.

Bearing in mind that the 308 aint a rocket ship anyway
I know 308 it's not a rocket ship as i've driven one before but still should rev more. Mine revs only to 3500 rpm and not 3000 so i guess it's not in a limp mode. Other things i've noticed when i bought it the engine was cutting off when using the indicator or flashing high beam lights. As one of the indicators wasn't working i've replaced it and is ok now. The dash seem to have been replaced and not a single light is working on the whole dash so i cant see the speedo whed driving in the dark.
username123 is offline  
Sponsored Links
Advertisement
 
#82 (permalink) Old 04-28-2010, 08:47 AM
BenzWorld Junior Member
 
Date registered: May 2009
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi can you help me i have a sprinter 2008 218 cdi v6 which for some reason has a fault with diesel entering the oil making the oil light come on some one says it could be the particle filter , the van is under warranty however mercedes are just changing the oil.
hull132 is offline  
#83 (permalink) Old 04-28-2010, 09:12 AM
BenzWorld Junior Member
 
Date registered: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by username123 View Post
I know 308 it's not a rocket ship as i've driven one before but still should rev more. Mine revs only to 3500 rpm and not 3000 so i guess it's not in a limp mode. Other things i've noticed when i bought it the engine was cutting off when using the indicator or flashing high beam lights. As one of the indicators wasn't working i've replaced it and is ok now. The dash seem to have been replaced and not a single light is working on the whole dash so i cant see the speedo whed driving in the dark.
The back end of the exhaust is disconected so i don't know if it's got something to do with that as well.
username123 is offline  
#84 (permalink) Old 04-28-2010, 10:41 AM
BenzWorld Newbie
 
Date registered: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
00 sprinter 208 cdi problem

hi guys wondering could u help me
i have a 208 cdi and it sunddenly just went in to limp mode and it runs some times but then can just cut out and not start i got the 4 codes read today and they are as follows
p1190 rail pressure current control valve open circuit
p1622 electric shut off valve open circuit
p1188 element shut off of high pressure pump open circuit
and p1470 charge pressure currnt control valce short circuit

any help would be great
gary28482 is offline  
#85 (permalink) Old 05-13-2010, 01:30 AM
BenzWorld Junior Member
 
Date registered: May 2010
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sprinter fuel gauge problem

I hope somebody can help me with a problem I have with the fuel gauge on my 2003 Sprinter 316 CDI (4x4)
The gauge shows full until the tank is about half empty and then starts to drop until it is showing about half empty and the tank is in fact pretty much empty.
I am wondering if there is any way of fixing the problem myself.
Any advice would be much appreciated.

Thanks.
graphicman is offline  
#86 (permalink) Old 05-28-2010, 10:58 AM
BenzWorld Newbie
 
Date registered: May 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Alternator wire colour needed

Hi
I am about to fit a leisure battery to a 2002 Sprinter 313 CDI LWB.
Can you tell me which wire and colour is the alternator warning light feed.
Thanks in advance for some invaluable help.
Cheers
t_revs is offline  
#87 (permalink) Old 06-04-2010, 04:32 PM
BenzWorld Member
 
DBTRANSPORT's Avatar
 
Date registered: Dec 2006
Vehicle: 316cdi 2002 and 319cdi 2009
Location: St Ives Cambs
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by t_revs View Post
Hi
I am about to fit a leisure battery to a 2002 Sprinter 313 CDI LWB.
Can you tell me which wire and colour is the alternator warning light feed.
Thanks in advance for some invaluable help.
Cheers
Dont bother trying to find it, just buy a voltage sensing relay (Ebay) ive just fitted one in my works van and was so simple just three wire's and it can hande up to 30amps
DBTRANSPORT is offline  
#88 (permalink) Old 06-04-2010, 04:34 PM
BenzWorld Member
 
DBTRANSPORT's Avatar
 
Date registered: Dec 2006
Vehicle: 316cdi 2002 and 319cdi 2009
Location: St Ives Cambs
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Anyone know where I can get an uprated front leaf spring for my 319cdi 2009 sprinter its already got the 3.8ton spring as standard cos of the v6 motor. Or does anyone have any info on fitting a spring of off the 5ton sprinters????
DBTRANSPORT is offline  
#89 (permalink) Old 06-22-2010, 04:18 PM
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Guest View Post
NEED HELP WITH YOUR CDI SPRINTER...DROP ME A LINE
hi sprintfix,having problems with my 311 cdi 2005 model,starting to get problems with van losing power,seems to go very flat and stuggles to get over 60mph with it,this only happens intermitently,replaced brake light switch as advised,cleaned maf sensor,had a look at vac pipes to unit on lower half of o/s/f wing,behind headlamp and also the vac ball which is sat with vac unit. when it plays up it sounds like air flow is restricted but you can still hear the turbo but not as prominant as when it is running ok,i have noticed that when it is playing up if you accelerate very gradual it seems to pull ok although this is not how it should be,blown air filter element clean and cleaned out the airbox. all intercooler pipes seem ok /no splits etc, ANY IDEAS?
graham ascough is offline  
#90 (permalink) Old 06-25-2010, 01:23 PM
BenzWorld Newbie
 
Date registered: Jun 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Can anyone advise me what is wrong with my Sprinter 316 brakes...they tend to pulse regularly when used. Any help will be appreciated very much as this vehicle has done this for three or more years now without remedy.

Cheers!!
Twatellies is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Vans/Trucks/SUV/Others > W901-905 Sprinter


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome