Mercedes-Benz Forum

Mercedes-Benz Forum (http://www.benzworld.org/forums/)
-   W220 S-Class (http://www.benzworld.org/forums/w220-s-class/)
-   -   P0130 and P0410 code (http://www.benzworld.org/forums/w220-s-class/1780505-p0130-p0410-code.html)

xgamers500 10-14-2013 09:30 PM

P0130 and P0410 code
 
Hy Guys!

I've got a 2001 S500. Check engine is on. I run a test on it, and it says this 2 codes: P0130 and P0410

The air injection pump is running by cold start! What else can be the problem?

Thank You

atmsmshr 10-19-2013 05:47 AM

Usually the cause of P0130 is a bad oxygen sensor, however this isn't always the case. If your o2 sensors haven't been replaced and they are old, it's a good bet that the sensor is the problem.

How many miles on the car, and have the O2 sensors been replaced? If more than 100,000 miles, replace both forward O2 sensors with Bosch of right fitment. (Do both sides as sensor 2, if not already replaced, has seen the same service interval and will go bad shortly.) Don't use the universal connectors, they are a pain to make up and may not last.

A bad Bank 1 sensor will set the P0410 code since the O2 sensors forward of the catalytic converter are used to measure the health of the smog pump.

I recently got a UScan Bluetooth adapter from Autozone and can trend O2 sensors from my iphone. Neat tool.


All times are GMT -7. The time now is 08:37 PM.

Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome