Outside Temp & Sunlight Sensor - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-27-2013, 10:35 AM   #1 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2013
Vehicle: 2002 S500
Location: South Padre Island - TX
Posts: 8
Outside Temp & Sunlight Sensor

I am having an issue with my 2000 S500. I have searched the forums and read the stickypedia for everything written on these topics.

My outside temperature display in the cluster is completely blank and the climate control diagnostics report that it is -40 outside instead of +85 here in Texas.
I replaced the temperature sensor in the lower left bumper - still nothing..
I followed the wires until they disappeared.. No damage can be seen.

My sunlight sensor has also just been replaced due to a 1270 error in the climate control diagnostics. I reset and ran the scan again and I still have the same error.

I checked the fuse charts and neither device is mentioned so I assume that they are not fused items but just connected to the vehicle data bus.

My question is whether these two items get power from or are connected to the data bus in the same location so I have a place to start digging?

Thanks in advance
Dan.

Last edited by englishdan; 09-28-2013 at 07:54 AM.
englishdan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-27-2013, 12:03 PM   #2 (permalink)
Moderator
 
Skylaw's Avatar
 
Date registered: Oct 2004
Vehicle: 2005 S500 4-Matic, 1978 450SL "Christine"
Location: Tampa, Florida
Posts: 7,346
Lifetime Premium Member
Dan, you have done everything that comes to mind - sorry I can't offer any good help. I hope someone can.

PS - I love the term "stickypedia"!!
__________________
Warren

2005 S500 4-Matic
with Gateway 500 iPod integration

1978 450SL restoration project

Formerly: 2000 S500
with Ice>Link iPod integration
Moto V710 phone with MikBox
Upgraded Voice Control

Last edited by Skylaw; 09-28-2013 at 10:05 AM.
Skylaw is offline   Reply With Quote
Old 09-28-2013, 05:23 AM   #3 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 47,303
You will need the wiring diagrams to follow this, sorry but my copy of WIS is not working at the moment or I would dig out the diagrams, maybe another member has a copy of WIS?
__________________
ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline   Reply With Quote
Old 09-28-2013, 07:57 AM   #4 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2013
Vehicle: 2002 S500
Location: South Padre Island - TX
Posts: 8
Quote:
Originally Posted by eric242340 View Post
You will need the wiring diagrams to follow this, sorry but my copy of WIS is not working at the moment or I would dig out the diagrams, maybe another member has a copy of WIS?
That would be great. I am going to look into getting my own copy. I have the feeling I am going to need it more than once during my ownership!
englishdan is offline   Reply With Quote
Old 09-28-2013, 12:09 PM   #5 (permalink)
BenzWorld Senior Member
 
Bullethead_D's Avatar
 
Date registered: Apr 2013
Vehicle: Car: 03 W220.184 (S500L 4matic)
Location: Germany
Posts: 403
The outside temperature sensor is connected to the SAM left. The instrument cluster and the clima control unit get the value over CAN-B.

The sunlight sensor is connected to the clima control unit.
Bullethead_D is offline   Reply With Quote
Old 09-28-2013, 01:19 PM   #6 (permalink)
Moderator
 
Skylaw's Avatar
 
Date registered: Oct 2004
Vehicle: 2005 S500 4-Matic, 1978 450SL "Christine"
Location: Tampa, Florida
Posts: 7,346
Lifetime Premium Member
Quote:
Originally Posted by englishdan View Post
That would be great. I am going to look into getting my own copy. I have the feeling I am going to need it more than once during my ownership!
See section 9 of the "stickypedia" for signing up for WIS.
Skylaw is offline   Reply With Quote
Old 10-02-2013, 09:56 AM   #7 (permalink)
BenzWorld Junior Member
 
Date registered: Sep 2013
Vehicle: 2004 S430
Location: USA
Posts: 5
Out Door Temp Sensor

Just Solved Same Problem Installed New Sun Sensor Didn't Help Found The Outdoor Temp Sensor Behind Small Oval Shape Grille Lower Drivers Side Spoiler
Pulled Grille Out Found Wires Had Slipped Loose Reattached Everything Works Perfect Now Reinstalled Old Sun Sensor Every thing Still Works Perfect
Used Contact Cleaner On Temp Sensor And Plug Were Very Green I Suspect That The Green Was The Issue All Along

Last edited by 1coolman; 10-02-2013 at 09:58 AM.
1coolman is offline   Reply With Quote
Old 10-02-2013, 08:55 PM   #8 (permalink)
BenzWorld Junior Member
 
Date registered: Aug 2013
Vehicle: 2002 S500
Location: South Padre Island - TX
Posts: 8
My sunlight sensor has some green on it too. I've used contact cleaner but I'm now going to use a needle on my meter lead to check continuity at the connector, if it fails I'm going to get creative with the soldering iron. Same goes for the temperature sensor.
Will keep you posted.
englishdan is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:04 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.