Car battery dies after left sitting for one or two days? - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-25-2011, 06:47 AM
BenzWorld Newbie
 
Date registered: Sep 2011
Vehicle: 2001 S500
Location: Lexington, Ky
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Car battery dies after left sitting for one or two days?

I just joined on here because I just bought a S500 2001 Mercedes and it has been in shop more then in my garage. I need some advice bad. My car battery dies about every two days and wont start totally dead. I took it to dealer and they ran a diagnostic on it and said that it was the command center which is the stereo and everything. They said it was cranking out to much voltage or something and it was the reason it wouldn't start every other day they said it would be 1k for new unit. I said nahhh can you just disconnect it or take fuse out. So they did. After few days the car would not start again! So they were incorrect!!!!!! what do I do???? Also I need a new a new suspension compressor cause everyday after parking it for the night the next morning when I go to car the front end is almost sitting on tire then when I would start it, it goes back up to normal. They said that wouldn't be the issue with the battery. SO does anyone have any info on this? I need help bad, its driving me crazy
Benz01-S500 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-25-2011, 07:18 AM
Lifetime Premium Member
 
deucer's Avatar
 
Date registered: Apr 2011
Vehicle: '02' S500 (W220)
Location: Lone Star State
Posts: 376
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
1. How old is your Battery? Will it hold a charge without connecting to car? Verify your battery will hold charge by having it tested at an Auto parts shop like AutoZone...
2. If battery is good and holds a charge, then it is possible for electrical drain after key is turned off due to the Command not shutting down properly, i.e. Radio, Navi or something is still running after shut down. Possible solution is to Push Power button (on center console) to OFF before turning key to off position. I can not confirm this works, but is plausible.
3.New Suspension Compressor replacement? Before you purchase, who troubleshot and concluded your compressor was bad? I'd would first be looking for a leak at the Strut or a fitting loose...

My 2 cents worth,
deucer
deucer is offline  
#3 (permalink) Old 09-25-2011, 12:24 PM
Moderator
 
Skylaw's Avatar
 
Date registered: Oct 2004
Vehicle: 2005 S500 4-Matic, 1978 450SL "Christine"
Location: Tampa, Florida
Posts: 7,649
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Lifetime Premium Member
Welcome to the forum.

The W220 S-Class Encyclopedia sticky at the top of the forum contains a section on excess quiescent battery drain under "Electrical System." What deucer advises is correct. The Encyclopedia links contain additional troubleshooting steps to identify the cause of the problem.

Warren

2005 S500 4-Matic
with Gateway 500 iPod integration

1978 450SL restoration project

Formerly: 2000 S500
with Ice>Link iPod integration
Moto V710 phone with MikBox
Upgraded Voice Control
Skylaw is offline  
#4 (permalink) Old 09-25-2011, 12:42 PM
BenzWorld Newbie
 
Date registered: Sep 2011
Vehicle: 2001 S500
Location: Lexington, Ky
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
thank you all so much, I'm gonna check it out... I keep thinking its the compressor draining the battery since it keeps dropping to tires when shut off then pumps it back up when started (when it starts).....
Benz01-S500 is offline  
#5 (permalink) Old 09-25-2011, 01:13 PM
Moderator
 
Skylaw's Avatar
 
Date registered: Oct 2004
Vehicle: 2005 S500 4-Matic, 1978 450SL "Christine"
Location: Tampa, Florida
Posts: 7,649
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Lifetime Premium Member
If you have an airmatic leak bad enough to drain your battery, it will also burn up your airmatic pump, very quickly. You'll want to tend to that promptly. See the S-Class Encyclopedia entries on Airmatic, too.

Warren

2005 S500 4-Matic
with Gateway 500 iPod integration

1978 450SL restoration project

Formerly: 2000 S500
with Ice>Link iPod integration
Moto V710 phone with MikBox
Upgraded Voice Control
Skylaw is offline  
#6 (permalink) Old 09-25-2011, 08:14 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,327
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 19 Post(s)
When you park the car for one or two days remove the airmatic relay, this will help to identify any drain via this means.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#7 (permalink) Old 09-26-2011, 11:48 AM
BenzWorld Newbie
 
Date registered: Sep 2011
Vehicle: 2001 S500
Location: Lexington, Ky
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
@ deucer I had the battery tested they said it was fine so idk. Wouldn't start this morning again. Called dealer and said hey car wont start again and fuse to command center is still out so that's not the problem.I said well I think its the compressor trying to pump the car back up after its in park or something. HE said maybe, so you'll need to get a new compressor. I said its pumping the car back up when started so why would I pay 624 for new compressor? Its obviously leaking out somewhere, he said well let me ask my Mercedes service guys and I'll call you back. I have never dealt with so much stress and problems from an automobile.
@eric242340 where is the airmatic relay at? How can I remove it?
Benz01-S500 is offline  
#8 (permalink) Old 09-26-2011, 01:49 PM
Lifetime Premium Member
 
deucer's Avatar
 
Date registered: Apr 2011
Vehicle: '02' S500 (W220)
Location: Lone Star State
Posts: 376
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Lifetime Premium Member
Assuming whomever tested your battery applied a load to it to ensure voltage would sustain, Good... Eric provided you with a great idea by popping the relay. If your compressor coming on and pumping pressure that much to drain your battery, you do have a serious leak somewhere and as Skylaw indicated, you need to find it. I think if you put your ear close enough on each side, underneath, you just might hear where it's leaking from...
deucer is offline  
#9 (permalink) Old 09-26-2011, 05:43 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,327
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 19 Post(s)
Quote:
Originally Posted by Benz01-S500 View Post
@ deucer I had the battery tested they said it was fine so idk. Wouldn't start this morning again. Called dealer and said hey car wont start again and fuse to command center is still out so that's not the problem.I said well I think its the compressor trying to pump the car back up after its in park or something. HE said maybe, so you'll need to get a new compressor. I said its pumping the car back up when started so why would I pay 624 for new compressor? Its obviously leaking out somewhere, he said well let me ask my Mercedes service guys and I'll call you back. I have never dealt with so much stress and problems from an automobile.
@eric242340 where is the airmatic relay at? How can I remove it?
Relay location;
Attached Thumbnails
Click image for larger version

Name:	Snap2.jpg
Views:	151
Size:	32.1 KB
ID:	400021  

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#10 (permalink) Old 10-10-2011, 12:01 AM
BenzWorld Member
 
Date registered: Dec 2009
Vehicle: 200 S500 W/144K miles
Location: Moorpark, CA
Posts: 85
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the same problem exactly. Firstly the battery tests can show its good when its really not so good. Secondly the thing that fixed my car is that the computer modules in the trunk were removed and cleaned and reconnected. Supposedly maybe from rain, water got in there and by removing and cleaning and reinstalling it solved the drain.
Good luck

1973 Porsche 911 RSR Project
1991 GMC Syclone
2000 Caddy Esc
2000 Benz S500
ArtisticEnt is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1991 300sl hard to start after sitting for a few days SailawaySG R129 SL Class 1 09-17-2009 12:38 PM
Rough Idle After Sitting for Few Days DMensik W203 C-Class 6 08-08-2009 09:37 AM
Loosing my MIND!!! Battery dead after 3 days of sitting. billabongo W220 S-Class 11 05-03-2008 12:47 PM
Will Headlights if left on Turn off Before the Battery Dies? MiamiMerc General Mercedes-Benz 4 05-16-2007 09:01 PM
Engine Noise after sitting a couple days charris R170 SLK Class 7 08-22-2004 06:58 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome