How do you reset Limp Home Mode - Mercedes-Benz Forum

Go Back   Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class
New User? Register - Forgot Password

BenzWorld.org is the premier Mercedes-Benz Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-26-2010, 04:52 AM   #1 (permalink)
BenzWorld Member
 
Date registered: Dec 2005
Vehicle: 97' S320 & 00' S500
Posts: 78
How do you reset Limp Home Mode

I need a bit of help please. I have a 2000 S500. I need to reset "Limp Home Mode" Last night I changed my front wheel bearings (inner and outer), and on the passenger side when I was lowering the vehicle I let off my hydraulic jack too quickly and the can dropped to the ground very quickly. On the test drive the car was in limp home mode with the dash light illuminated. I dont think anything is really wrong as the car was running fine before all of this. I have done this procedure on many vehicles including my older W123's, W126's, and my W140. The reason I changed the wheel bearings is I needed an alignment to correct for a slight pull and the mechanic told me that there was too much play in the bearings for him to align the car accurately. How do you reset this mode?
kcscout is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-26-2010, 05:53 AM   #2 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,119
If you have the diagnostic test equipment then clear the fault codes and as long as nothing is seriously wrong limp mode problem will go away.
__________________
ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now   Reply With Quote
Old 03-26-2010, 06:26 AM   #3 (permalink)
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
Is there a limp home mode light in 2000 S500? where is the light? Or you refer to the check engine light or you refer to the message on the display?

My experience on my other MB (ML320) to get out of limp home mode is to disconnect battery for 5 minutes. Worked twice so far. However, the dealer told me I just lucky...
idahombz is offline   Reply With Quote
Old 03-26-2010, 06:28 AM   #4 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,119
Quote:
Originally Posted by idahombz View Post
Is there a limp home mode light in 2000 S500? where is the light? Or you refer to the check engine light or you refer to the message on the display?

My experience on my other MB (ML320) to get out of limp home mode is to disconnect battery for 5 minutes. Worked twice so far. However, the dealer told me I just lucky...
Disconnecting the battery does sometimes work, a bit hit and miss really. And there is no Limp mode light, usually the check engine will remain lit and the car is locked in second gear.
eric242340 is online now   Reply With Quote
Old 03-26-2010, 06:37 AM   #5 (permalink)
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
Quote:
Originally Posted by eric242340 View Post
Disconnecting the battery does sometimes work, a bit hit and miss really. And there is no Limp mode light, usually the check engine will remain lit and the car is locked in second gear.
exactly! Once I have to disconnect 3 times (then test drive 3 times) to get out of limp home.

Without drive the vehicle, how can I tell (from Dash or OBDII) that limp home mode is gone?
idahombz is offline   Reply With Quote
Old 03-26-2010, 06:40 AM   #6 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,119
Quote:
Originally Posted by idahombz View Post
exactly! Once I have to disconnect 3 times (then test drive 3 times) to get out of limp home.

Without drive the vehicle, how can I tell (from Dash or OBDII) that limp home mode is gone?
Limp mode means the car will not shift above second gear so if it shifts normally then she is out of limp mode.
eric242340 is online now   Reply With Quote
Old 03-26-2010, 06:43 AM   #7 (permalink)
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
correct! That's how i figure if my disconnect battery worked or not. My question is , is there any way to tell without driving. Thank you!

BTW what do you do in the donkey's home town?
idahombz is offline   Reply With Quote
Old 03-26-2010, 06:45 AM   #8 (permalink)
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,119
Quote:
Originally Posted by idahombz View Post
correct! That's how i figure if my disconnect battery worked or not. My question is , is there any way to tell without driving. Thank you!

BTW what do you do in the donkey's home town?
1, NO you must drive to understand if it is or is not.

2, Business partner and MB Tech
eric242340 is online now   Reply With Quote
Old 03-26-2010, 06:53 AM   #9 (permalink)
BenzWorld Senior Member
 
Date registered: Jan 2008
Vehicle: 98 ML320 7 Seats, all options 01' S500
Posts: 567
Thumbs up

thank you! and enjoy!
idahombz is offline   Reply With Quote
Old 03-26-2010, 07:58 AM   #10 (permalink)
BenzWorld Member
 
Date registered: Dec 2005
Vehicle: 97' S320 & 00' S500
Posts: 78
Will a Code Reader work

Will a standard OBD II Code Reader work, or do I need some special disgnostic equipment specifically for the MB.
kcscout is offline   Reply With Quote
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W220 S-Class

Bookmarks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Topic Author Forum Replies Last Post
Limp Home Mode MikaHakkinen R129 SL Class 9 06-30-2011 06:43 AM
Why a reset (disconnect Battery) can have the truck get out of limp home mode? idahombz W163 M-Class 18 03-31-2010 12:43 PM
Limp Home Mode Andrzejek W202 C-Class 21 02-04-2010 08:48 AM
Limp Home Mode HELP eapen W210 E-Class 4 05-04-2009 05:27 PM
Limp home mode? rlbmd2006 W203 C-Class 0 08-27-2007 10:27 AM


All times are GMT -7. The time now is 03:37 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.1

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.