Command System upgrade - Page 4 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #31 of 37 (permalink) Old 01-10-2015, 01:32 AM
BenzWorld Junior Member
 
Date registered: Nov 2008
Vehicle: 2015 Mercedes Benz CLS400
Location: Orange County
Posts: 14
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Send a message via Skype™ to imilad
Hello guys...

I just purchased my 2010 w212 about two weeks ago.. I was bummed when I noticed that the BT AUDIO was not showing in the menu.. Did some reading online and discovered the "engineering menu" .. With lots of excitement I enabled it. But came to great disappointment as every time I would try to connect it would only display with "Authorization Unsuccessful"

Did some more research...

enabling BT AUDIO from engineering mode will allow you to externally authorize your phone, but what it does is, de authorize BT PHONE functionality.. In other words you can only have either or. I was testing all of this from my iPhone 6 so I knew the issue was not from my phone as it has the latest BT 4.0LE chip in it.

Called up the dealer and made an appointment. Got super lucky as I realized my car still had a cert pre owned warranty until next month. picked it up today and both Audio & Phone is working.

Point is,, It will only work with the software upgrade on the command unit...

...


Now I am trying to go couple steps further to get iPhone mirroring onto the unit.. If anyone has any suggestions I would appreciate that allot.

Thank you
imilad is offline  
Sponsored Links
Advertisement
 
post #32 of 37 (permalink) Old 01-11-2015, 01:01 PM
BenzWorld Newbie
 
Date registered: Jan 2015
Vehicle: 2011 E350 Wagon 4matic
Location: Ontario Canada
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
switch to new blackberry Passport. Get $500 toward new phone that works with the car. Sorry just had to. Die hard BB customer
BERNIETHEGERMAN is offline  
post #33 of 37 (permalink) Old 01-04-2016, 02:27 PM
BenzWorld Veteran
 
Date registered: Mar 2008
Vehicle: 2010 ML 350 Bluetec 4Matic
Location: Kentucky
Posts: 700
Mentioned: 1 Post(s)
Quoted: 118 Post(s)
Does anyone know if there is a firmware update to add audio streaming in MY 2009 and 2010 164 ML. Thanks in advance.
james.calton1 is offline  
 
post #34 of 37 (permalink) Old 01-05-2016, 08:28 AM
BenzWorld Junior Member
 
Date registered: May 2013
Posts: 28
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by imilad View Post
Hello guys...

Now I am trying to go couple steps further to get iPhone mirroring onto the unit.. If anyone has any suggestions I would appreciate that allot.

Thank you
WHat are you trying to mirror?
TXDiesel22 is offline  
post #35 of 37 (permalink) Old 04-09-2016, 10:09 PM
BenzWorld Member
 
Date registered: Mar 2012
Vehicle: 2007 CLK 350 convertible, 2010 E350 4matic
Posts: 117
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
I just got the Samsung Galaxy S7 Edge and this phone pure and simply does not like to cooperate with the bluetooth in the COMAND. I do not believe my car had the COMAND firmware upgrade yet. First off, I can only successfully pair the phone to the COMAND deck only if all other authorized phones have been deleted from the list. Secondly, it works fine when it is initially paired. However, once I park the car, turn off the engine, and the bluetooth automatically disconnects, it will never connect again when I go to start up the car. The phone tries to connect to COMAND, but then the connection fails and an error message pops up on the phone screen that the phone was unable to communicate with the car's bluetooth.

The only way that I can get it to pair again is to unpair the connection from the phone with the car off, turn off bluetooth, then start the car and de-authorize the phone from the COMAND bluetooth. Once the phone is de-authorized, I can then turn on bluetooth on the phone and start the pairing process again from scratch. This is a ridiculous 5-10 minute process to have to go through every time you get in the car and want to drive somewhere and be able to make phone calls hands-free. It's not an issue with the handset because it works fine with a Pioneer head unit in my son's car, and works fine with bluetooth headsets and speakers. And I've paired and used a number of different phones for phone audio (bluetooth phone calls) and never had any issues, which started with the HTC Rezound and almost every version of Samsung phone (Galaxy S3, S4, S5, Note 2, Note 3, Note 4 and Note 5).
jseah is offline  
post #36 of 37 (permalink) Old 04-10-2016, 07:11 PM
BenzWorld Member
 
Favog's Avatar
 
Date registered: Mar 2014
Vehicle: 2014 E250
Location: USA
Posts: 214
Mentioned: 0 Post(s)
Quoted: 55 Post(s)
My iPhone 5 plays nicely with COMAND in my 2014 E250. No complaints whatsoever.
Favog is offline  
post #37 of 37 (permalink) Old 04-14-2016, 11:41 AM
BenzWorld Newbie
 
Date registered: Apr 2016
Vehicle: 2010 e class cabrio
Location: ireland
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
did you try this ?

10 Common Samsung Galaxy S7 problems and how to fix them

scroll to BLUETOOTH CONNECTION ISSUES

Ale

Quote:
Originally Posted by jseah View Post
I just got the Samsung Galaxy S7 Edge and this phone pure and simply does not like to cooperate with the bluetooth in the COMAND. I do not believe my car had the COMAND firmware upgrade yet. First off, I can only successfully pair the phone to the COMAND deck only if all other authorized phones have been deleted from the list. Secondly, it works fine when it is initially paired. However, once I park the car, turn off the engine, and the bluetooth automatically disconnects, it will never connect again when I go to start up the car. The phone tries to connect to COMAND, but then the connection fails and an error message pops up on the phone screen that the phone was unable to communicate with the car's bluetooth.

The only way that I can get it to pair again is to unpair the connection from the phone with the car off, turn off bluetooth, then start the car and de-authorize the phone from the COMAND bluetooth. Once the phone is de-authorized, I can then turn on bluetooth on the phone and start the pairing process again from scratch. This is a ridiculous 5-10 minute process to have to go through every time you get in the car and want to drive somewhere and be able to make phone calls hands-free. It's not an issue with the handset because it works fine with a Pioneer head unit in my son's car, and works fine with bluetooth headsets and speakers. And I've paired and used a number of different phones for phone audio (bluetooth phone calls) and never had any issues, which started with the HTC Rezound and almost every version of Samsung phone (Galaxy S3, S4, S5, Note 2, Note 3, Note 4 and Note 5).
alezx is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W212 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2009/2010 COMMAND system upgrade from 2006 on CLS500 ???'s Help Please! The_Dream_CLS Audio & Telematics Forum 20 07-02-2012 12:22 AM
    Does MB charge to upgrade the command system? BootyHunter57 W221 S-Class 10 05-26-2011 09:21 AM
    Command System Upgrade dlynch4008 W220 S-Class 6 02-27-2011 02:52 PM
    2009/2010 Command System Upgrade ???'s! Help Please! The_Dream_CLS C219 CLS-Class 0 10-13-2009 08:06 AM
    COMMAND SYSTEM / SOUND SYSTEM '01 S500 robertindallas W220 S-Class 1 03-18-2008 05:04 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome