05 E55 "chirping" noise when downshifting - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-03-2011, 10:13 PM
BenzWorld Junior Member
 
Date registered: Jul 2011
Vehicle: 05 E55 AMG
Location: Portland OR, USA
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
05 E55 "chirping" noise when downshifting

Hello

Bought my E55 AMG about a month ago. It has 62k and was well maintained at the local dealership before it came to me. It seems flawless in every way and everything seems functional with a few electrical glitches that will be easily fixed. I have however noticed a kind of chirping noise when it downshifts into a lower gear when you accelerate while rolling along. Seems almost like a slight belt slip type of noise and not a metal clang or clunk. It shifts like butter and there are no malfunctions in its operation otherwise. Any ideas what this could be? Any thoughts are greatly appreciated.

Cheers, Jon
purplehayes is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-04-2011, 07:21 AM
BenzWorld Junior Member
 
Date registered: Sep 2009
Vehicle: 2007 e63. Iridium Silver.
Location: Louisville, KY
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I beleive that many folks on other forums have discussed the infamous "supercharger chirp". Fairly normal occurrence for you e55 guys.

Check here:

chirping sound coming from the engine?? - MBWorld.org Forums
lawguy is offline  
#3 (permalink) Old 08-04-2011, 11:43 AM
BenzWorld Elite
 
EvoGuy's Avatar
 
Date registered: Dec 2006
Vehicle: 2004 E500 Wagon, 2004 E55 AMG
Location: ATL
Posts: 1,327
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the same problem, from what I've heard there's nothing to worry about! I just got used to it.
EvoGuy is offline  
#4 (permalink) Old 08-04-2011, 01:00 PM
BenzWorld Junior Member
 
Date registered: Jul 2011
Vehicle: 05 E55 AMG
Location: Portland OR, USA
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
That's great info guys. Good to know it is very common and nothing tragic. Thank you for the link too. Didn't think of searching for chirping, lol! I can sleep better now.

Cheers
purplehayes is offline  
#5 (permalink) Old 08-06-2011, 10:42 AM
BenzWorld Junior Member
 
Ike Luv's Avatar
 
Date registered: Jul 2011
Vehicle: 2005 Brilliant Silver E55 AMG
Location: Westchester NY
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I notice it also, I have gotten used to it as well. My last visit to the stealership, the service advisor just shook his snake head & said "ssss,... don't worry about it,sssss..."
Ike Luv is offline  
#6 (permalink) Old 08-12-2011, 03:16 PM
BenzWorld Junior Member
 
trbod's Avatar
 
Date registered: Jan 2007
Vehicle: 2004 E55
Location: Dallas
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quick and skinny answer is that unlike other supercharged engines its supercharger isn't constantly engaged, there's a throttle controlled clutch to engage it. So when that clutch engages guess what happens? It makes a chirp on the belt, much like your shoe chirping on a basketball court.

Try changing the transmission from comfort to sport and notice how it engages the supercharger much faster in sport mode.
trbod is offline  
#7 (permalink) Old 09-09-2011, 01:13 AM
BenzWorld Junior Member
 
Date registered: Sep 2011
Vehicle: White W212, Black GTR
Location: OC, Cali
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I think they got tired of fixing this. My buddies SL55 they actually fixed it for him by changing out the electric clutch that controls the supercharger. For my old E55 they lubed it up, but the chirp just came back after a few thousand miles. You pretty much have to get used to it...
gh429 is offline  
#8 (permalink) Old 01-04-2012, 04:40 PM
BenzWorld Member
 
E55-SAMMY's Avatar
 
Date registered: Mar 2008
Vehicle: 2003 CL 55 AMG K / 2004 AUDI RS6
Location: CORNWALL, ENGLAND
Posts: 144
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Its ok you can put up with it but the bearings will seize up in the end as mine did you will know when it happens as you will lose the power of the super charger all together and/or the power will stuter but you will still get the chirping noise it happend to me and the same has happend again as i got a senond hand komprossor pully instead of the pully repair kit with the new clutch ive also ordered a new bearing with the black seal on the front its a Nachi Supercharger Bearing Nachi part no. 45BG07S5AIG-2DL these are the newer bearings and last a lot longer than the old ones with the orange front cover
E55-SAMMY is offline  
#9 (permalink) Old 01-06-2012, 01:48 PM
BenzWorld Junior Member
 
Ike Luv's Avatar
 
Date registered: Jul 2011
Vehicle: 2005 Brilliant Silver E55 AMG
Location: Westchester NY
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Since I posted on this thread, I have had to replace my SC pulley/ clutch assembly. I heard the chirp one time since, which was right after the repair was done. I don't know if it was all in my mind but it seemed like the SC clutch wasn't engaging, until I did a hard WOT one time, heard the chirp then it seemed like it went back to normal. Haven't heard the chirp since.
Ike Luv is offline  
#10 (permalink) Old 01-06-2012, 05:23 PM
BenzWorld Member
 
Date registered: Sep 2011
Vehicle: E55 2006 / E55 2000 / White Odyssey
Location: California
Posts: 169
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Ike Luv View Post
Since I posted on this thread, I have had to replace my SC pulley/ clutch assembly. I heard the chirp one time since, which was right after the repair was done. I don't know if it was all in my mind but it seemed like the SC clutch wasn't engaging, until I did a hard WOT one time, heard the chirp then it seemed like it went back to normal. Haven't heard the chirp since.
How much did you pay for the SC clutch with bearing ?
E55k is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz AMG Forums > W211 E55 AMG, E63 AMG


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome