W211 vibration when accelerating and loss of power - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-30-2013, 02:40 PM
BenzWorld Newbie
 
Date registered: Aug 2013
Vehicle: W211 E220 2004
Location: Albania
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
W211 vibration when accelerating and loss of power

So i own a w211 e220 2004

The car vibrates at 55 - 60 mph when accelerating. I've also noticed that fuel consumption is less than normal. It had been suffering a power loss problem when warmed up after an hour's driving. Basically it would only accelerate very slowly.

Humming/droning noises, or jolting during gentle acceleration between engine speed of 1200 - 2500 rpm.

I have a behr radiator, i have made the glycol test and it was clear, no glycol contamination. And the EGR valve is cleared

So what do you think... any help?
Sorry about my bad english
moli23 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-31-2013, 12:14 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 14,417
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 78 Post(s)
Lifetime Premium Member
Possible injector or fuel supply issue?

Is the check engine light on?

Hoe many KMs are on the car?
Noodles is offline  
#3 (permalink) Old 08-31-2013, 02:21 AM
BenzWorld Newbie
 
Date registered: Aug 2013
Vehicle: W211 E220 2004
Location: Albania
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Noodles View Post
Possible injector or fuel supply issue?

Is the check engine light on?

Hoe many KMs are on the car?
No, there is no check engine light on, even STAR doesn't show anything... everything seems fine

170,000 KM
moli23 is offline  
#4 (permalink) Old 08-31-2013, 04:13 AM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 14,417
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 78 Post(s)
Lifetime Premium Member
Were the injectors visually inspected on the fuel rail to make sure they are sealed and not leaking?
Noodles is offline  
#5 (permalink) Old 09-01-2013, 03:21 AM
BenzWorld Newbie
 
Date registered: Aug 2013
Vehicle: W211 E220 2004
Location: Albania
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Noodles View Post
Were the injectors visually inspected on the fuel rail to make sure they are sealed and not leaking?
yes , no probs with the injectors
moli23 is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome