how to change 2006 E350 secondary air pump and fuse - Mercedes-Benz Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-29-2012, 11:08 PM
BenzWorld Junior Member
 
Date registered: Nov 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
how to change 2006 E350 secondary air pump and fuse

Hi, I have a 2006 E350 (base) W211, recently I have a check engine light on, so I take the car to a MB dealer, and after 2hrs, they tell me the secondary airpump failed, and will cost me $1200 to get a new one, including parts and labor. Is anybody can help me out, where I can locate the secondary air pump and how to replace it or can I just fix the pump by myself. P.S. do I need change the relay too,and where is it?
thanks
MK

Last edited by markde; 11-29-2012 at 11:20 PM.
markde is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-30-2012, 02:34 AM
BenzWorld Elite
 
Roadking999's Avatar
 
Date registered: Apr 2008
Vehicle: E350 4M 06
Location: Snow Belt
Posts: 2,099
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
If you remove the front engine cover, the secondary air pump is sitting on top looking at you, its 2/3 the size of the alternater, its black with hoses and wires connected to it, it has 3 or 4 bolts.
Usually these things burn up when the relay goes bad and they stay on all the time.
If you want to go the cheapest way, you can send yours to this guy in Brooklyn and he will repair it for $95:
261135429389 (ebay item)
I havent used his services but the reports on him are good.
The relay is in the engine compartment, drivers side box. I highly recommend that you replace it as well.
When done, the CEL can be removed with SDS, it may cost you 30 minutes at ther dealer which in our case is $456,980,456,000.00
Roadking999 is offline  
#3 (permalink) Old 11-30-2012, 06:59 PM
BenzWorld Junior Member
 
Date registered: Nov 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you so much, I will work on it this weekend. I will post the update soon
markde is offline  
#4 (permalink) Old 12-01-2012, 06:04 PM
BenzWorld Junior Member
 
Date registered: Nov 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
I just open the driver side fuse box, open the fuse chart, but I can't found the relay box number for the secondary air pump. Anybody can tell me the relay number or the part number. Thanks ahead
MK
markde is offline  
#5 (permalink) Old 12-01-2012, 06:28 PM
BenzWorld Elite
 
Roadking999's Avatar
 
Date registered: Apr 2008
Vehicle: E350 4M 06
Location: Snow Belt
Posts: 2,099
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
N10/1kR
Attached Thumbnails
Click image for larger version

Name:	mercedes sap picture.jpg
Views:	2515
Size:	41.1 KB
ID:	482453  
Attached Images
 

Last edited by Roadking999; 12-01-2012 at 06:43 PM.
Roadking999 is offline  
#6 (permalink) Old 12-01-2012, 11:38 PM
BenzWorld Junior Member
 
Date registered: Nov 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thank you so much, work on it
markde is offline  
#7 (permalink) Old 06-04-2013, 09:19 PM
BenzWorld Junior Member
 
Date registered: Nov 2012
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
change the pump and relay N10/1kR ,but pump still not working, try to find the fuse, but I can't find it, can anyone tell me where is the fuse for the air pump, thanks a lot ahead:>
markde is offline  
#8 (permalink) Old 01-18-2014, 01:02 PM
BenzWorld Newbie
 
Date registered: Jan 2014
Vehicle: 2006 e350
Location: Los Angeles
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Markde did you ever solve the issue, I am now having the same problem.
Corleto is offline  
#9 (permalink) Old 09-06-2014, 02:23 AM
BenzWorld Newbie
 
Date registered: Sep 2014
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Roadking999 View Post
N10/1kR
I have changed the secondary air pump / relay / fuse & still won't work, I'm in Australia RHD & I think I may have mistakenly identified the wrong relay. The photo as illustrated is not clear enough to positively identify the correct relay that I think I'm needing, could a member possibly furnish a more clear photo please. With thanks & cheers.
Buldog is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome