Oil level E320 CDI -2006 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-21-2012, 05:26 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2007
Vehicle: 2002 E 320; 2002 E320 wagon, 2006 E320 CDI, 2010 ML 350 Bluetec, 1981 SD300
Location: Texas
Posts: 141
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
(Thread Starter)
Oil level E320 CDI -2006

I looked over the forum and I tried to find the answer but I couldn't get it clear.
Would you please help me with an clear answer based on your experience?
I just changed the engine oil on my (new to me) 2006 E320 CDI (32000 miles).
I used 5W-40 Mobil 1 ESP (229.51). The oil was drained (bottom plug).
The new filter is HENGST (from Autohaus). I drained a total of 9 quarts of oil. The book calls for 8 quarts. The oil level dash message is telling me that the level is OK. (I have to remind you that this car doesn't have dipstick and at this time I do not have the tool to measure the oil - so I have to rely on the computer).
I managed to get into the " secret" dyno mode to read the oil quantity.
To my surprise the computer is telling me I have only 6.9 quarts (not liters).
I checked it twice and the car was given hours of settling on a leveled surface ( garage). With the car running the quantity measured ( dyno mode) drops to 5.9 quarts - probably this doen't mean much rather than the sensor is working .
Any idea if this is right ?
Again:
- drained 9 quarts
- put in 8 quarts ( per manual)
- computer - " Oil level OK"
- checked with " dyno mode" screen - quantity 6.9 quarts ( not liters).
Where one quart that I know I put in disappeared? Why the computer is OK with 6.9 quarts without telling me to add one? Why before was not waning me that I had too much oil ( 9 quarts)?

Thank you much for your answers.
catalind is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-21-2012, 07:08 PM
Moderator
 
Date registered: Jul 2005
Vehicle: 90 300E, 99 ML430, 00 ML320, 05 E500 4matic Wagon
Location: WI
Posts: 18,516
Mentioned: 17 Post(s)
Quoted: 810 Post(s)
Lifetime Premium Member
The display will say it is OK with it being a bit low.
It was over full at 9 quarts. In the owners manual and the service DVD the car holds
8 quarts.
I do not think your sensor is malfunctioning. The computer accounts for what is in the
filter and filter housing which is at least a half quart. The sensor reads the pan level,
the computer knows there is a certain amount in the filter and housing and it is OK.
If you want to add a quart you can, but it might tell you that it is too full and you would
have to drain some or use a suction device to pull it out of the tube.
Noodles is offline  
post #3 of 3 (permalink) Old 03-22-2012, 04:43 AM
BenzWorld Member
 
Date registered: Feb 2008
Vehicle: 2006 E320 CDI
Location: Northern Virginia
Posts: 386
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by catalind View Post
I looked over the forum and I tried to find the answer but I couldn't get it clear.
Would you please help me with an clear answer based on your experience?
I just changed the engine oil on my (new to me) 2006 E320 CDI (32000 miles).
I used 5W-40 Mobil 1 ESP (229.51). The oil was drained (bottom plug).
The new filter is HENGST (from Autohaus). I drained a total of 9 quarts of oil. The book calls for 8 quarts. The oil level dash message is telling me that the level is OK. (I have to remind you that this car doesn't have dipstick and at this time I do not have the tool to measure the oil - so I have to rely on the computer).
I managed to get into the " secret" dyno mode to read the oil quantity.
To my surprise the computer is telling me I have only 6.9 quarts (not liters).
I checked it twice and the car was given hours of settling on a leveled surface ( garage). With the car running the quantity measured ( dyno mode) drops to 5.9 quarts - probably this doen't mean much rather than the sensor is working .
Any idea if this is right ?
Again:
- drained 9 quarts
- put in 8 quarts ( per manual)
- computer - " Oil level OK"
- checked with " dyno mode" screen - quantity 6.9 quarts ( not liters).
Where one quart that I know I put in disappeared? Why the computer is OK with 6.9 quarts without telling me to add one? Why before was not waning me that I had too much oil ( 9 quarts)?

Thank you much for your answers.
My 06 E320 CDI also shows 6.9-7.0 quarts when checked using what you call the Dyno Mode -- Access from the instrument cluster via the service infor. Don't add unless the system tells you to add a quart and it will if it is working correctly. Never had to add on the CDI but my C320 will use a quart during changes and it always asks when it wants it.
edwinwalke is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W211 E-Class

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2006 check oil level electronically aminoacid W203 C-Class 9 05-19-2010 10:38 AM
    99 E320: Oil Level Cluster Reading kwhombre W210 E-Class 5 02-04-2010 07:32 AM
    help 2006 c280 oil level sensor 1985mercedesbenz General Mercedes-Benz 2 11-08-2009 11:16 AM
    99 e320: A/C Coolant Level Check kwhombre W210 E-Class 3 07-24-2009 06:59 PM
    bad oil level sender on a 1994 e320 e320r W124 E,CE,D,TD Class 3 03-15-2005 07:21 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome